Recent Purchase - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-24-2006, 05:52 PM Thread Starter
BenzWorld Junior Member
BenzSDL's Avatar
Date registered: Mar 2006
Vehicle: '87 420 SEL & 300SDL
Location: Washington DC
Posts: 18
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Recent Purchase

I recently purchased a 1987 300SDL. It's my third W126-body Benz. I love these cars. This car is my second diesel. I had a 83 300SD which was basically a rolling project car . I tinkered, twiddled, and fiddled with everything on that car. You name it, and I probably fixed or replaced it. I learned about everything relating the body and suspension and also learned a lot about the engine. When I bought it, it ran poorly but when I was done, it ran great. However the tranny went bad, and at 275K miles, it was time to say good bye (I don't do transmissions). However the 300SDL seems a little more serious. Unlike the 300SD with its detroit-style all cast iron bullet proof engine, the 300SDL powerplant seems a little more sophistocated. Aluminum head makes me a little nervious but six cylinders is much smoother and quieter than 5.

My first question is that the car is sluggish in second and third gear. Step on the accelerator between 25 and 40 mph and everyone behind me disappears in black smoke. I can feel the turbo boost, but it's really delayed. If I really mash on the accelerator, the engine replies with a loud rattling as if to say "watch it pal". The car did have the trap recall fixed, but I am wondering if there is something more serious. My 300SD had the same problem, so I tweaked the altitude compensator, which helped some. I also gave it a heavy dose of injector cleaner (basically a full bottle on a near empty tank several times). After that, it ran fantastic. What things should I be careful about with the 300SDL engine? The fuel door says "no additives" and so I have not given it any injector cleaner. It starts well even at 15F so I think its basically in good shape. Any tips would be helpful.
BenzSDL is offline  
Sponsored Links
post #2 of 3 (permalink) Old 03-24-2006, 08:29 PM
BenzWorld Elitist
Marsden's Avatar
Date registered: Dec 2005
Vehicle: Mercedes-Benz
Location: United States
Posts: 11,295
Mentioned: 3 Post(s)
Quoted: 397 Post(s)
Lifetime Premium Member
RE: Recent Purchase

See " ** READ ** Before posting here " in this Forum.

The 126 people will be able to help you, try there.

Marsden is offline  
post #3 of 3 (permalink) Old 03-24-2006, 09:23 PM
BenzWorld Member
FireFox31's Avatar
Date registered: Sep 2005
Vehicle: Green '02 E320 Wagon
Location: NJ
Posts: 336
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: Recent Purchase

The 300SD was a 5 cylinder? Odd, I thought only Volvo (850, V70, etc) used that odd size? My V70 feels a little less "exclusive by oddity" now.

Getting my Benz back on the road one step at a time
FireFox31 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome