D-jet trigger point question. - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-21-2006, 07:57 AM Thread Starter
BenzWorld Junior Member
JBR's Avatar
Date registered: Oct 2005
Vehicle: 73 450SL
Location: NE PA
Posts: 47
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
D-jet trigger point question.

I am trying to get my 73 450sl set at 5*atdc. I have found one problem and that was that the plug wires were not put on the dist. cap correctly.
I have removed the trigger points and cleaned but apon reinstalling they don't go in all the way. The screw holes line up perfect but there is a slight gap where the point tray housing meets the dist. housing.
It looks as if it used to have a gasket at one time, and that might be why I see a gap. I plan to use some black silicone to fill the space. Is this the wrongthing to do? thanks
JBR is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome