1994 S 350 T Diesel power problem. "Experienced Help, ..PLEASE"!! - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-13-2006, 06:15 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2006
Vehicle: 1994 S 350 Turbo Diesel
Location: Toledo
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1994 S 350 T Diesel power problem. "Experienced Help, ..PLEASE"!!

Complete rebuilt motor w/updated rods(metric motors). Injection pump, turbo rebuilt. New fuel tank, screen filters. 30000 miles on rebuild. First 20000 miles, found vacume hose to turbo wastegate not connected, solved most problems BUT... when I first start it up in the morning-dead cold, this motor pulls real hard if I wish it to. Downshifts great and not a worry in the world. Give it ten minutes and 40% of the power is gone. Wont downshift unless I punch it through the firewall.. Very slow pick-up, so on a long drive, Im getting 21 mpg. I have seen 30+ mpg, once! I found sludge in the tank so I replaced it.. Now, check this out! While at speed, and motor has been up to temp. or after the first start in the day, Ive shut-off the motor, restarted it, back in drive and ALLS WELL AGAIN!? Within 2-3 minutes after the restart, Ive lost the power again. So Ive tried the last process over and over w/same results, scratch my head. Every time I shut this car off, walk away and come back, runs great, for 2-3 minutes. Electrical is one part of the problem I know, BUT IM PULLING MY HAIR OUT. Please, Please.... Anyone "experienced" with the 603 diesel in the form of a 94 S Class, I need the help badly. Many, Many Thanks!!!!!
s350turbo is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-14-2006, 03:10 PM
BenzWorld Junior Member
 
Date registered: Oct 2003
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 1994 S 350 T Diesel power problem. "Experienced Help, ..PLEASE"!!

your EGR valve is not working
rhgtara is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome