Overheating S420 - Page 2 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 14 (permalink) Old 06-25-2011, 03:54 PM
BenzWorld Junior Member
 
Date registered: Apr 2011
Vehicle: 1995 s420
Location: seacoast nh
Posts: 20
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I have seen both fans turning recently - the driver side is slightly slower. Anyone have a pic of the sensor that controls these? I can't seem to find it - I read that if you disconnect it the fans will run on high all the time.
188k s420 is offline  
Sponsored Links
Advertisement
 
post #12 of 14 (permalink) Old 06-25-2011, 09:06 PM
BenzWorld Member
 
Minnet's Avatar
 
Date registered: May 2005
Vehicle: 1991 300SEL W140, Brabus, W220 facelift
Location: Denmark
Posts: 196
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
It might be the main fan drive (viscous coupling) or simply incorrect position of the fan shroud causing the fan not to obtain adequate speed.

I had that problem, and it gave exactly the symptoms as you describe.

In the beginning that was further assisted by one of the auxillary fans going wrong way. Anyway, the auxillary fans are controlled by the A/C thermostat - not the coolant thermostat - so you are on wrong track.

1991 300SEL W140, Brabus, W220 facelift
1987 190E 2,3
1987 Honda Accord 2,0
Minnet is offline  
post #13 of 14 (permalink) Old 06-28-2011, 07:48 PM
BenzWorld Junior Member
 
Date registered: Jun 2011
Vehicle: 1993 W140 500SEL- 90K miles White/Palomino, 1985 W126 380SE- 170K miles Grey/Black
Location: Detroit, MI
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Seri,

Is your A/C blowing cold when this overheating occurs? If the system is at good efficiency, you should see about a 20 degree temperature difference between the ambient air and the center vents in the vehicle (using a thermometer) with the setting on MAX cold.
Be sure that your A/C condensor isn't restricted with debris in addition to checking your viscous clutch. If it is,you'll generally have less airflow and diminished engine radiator cooling as a result. Just an FYI...
asvmac is offline  
post #14 of 14 (permalink) Old 06-29-2011, 01:47 AM
BenzWorld Member
 
Minnet's Avatar
 
Date registered: May 2005
Vehicle: 1991 300SEL W140, Brabus, W220 facelift
Location: Denmark
Posts: 196
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Just as I made a mistake... Seri's post is 5 years old

1991 300SEL W140, Brabus, W220 facelift
1987 190E 2,3
1987 Honda Accord 2,0

Last edited by Minnet; 06-29-2011 at 01:49 AM.
Minnet is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome