engine won't stop!! - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 12-28-2005, 09:17 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2005
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
engine won't stop!!

Here is the problem[:O]. I recently acquired a 1984 190D. When I got the car it needed a new starter motor as the old one was shot and would not work. I put the stator motor in, not an easy task. Now the engine starts up fine but when I turn the key to turn the engine off it does not kill the engine…[:(!] I was told by the previous owner that the engine started and stopped fine before the startor motor went. I can remove the key and the engine keeps on running. Lucky it is a manual so I can stall it to kill the engine. Has anyone ever had such a problem? Where do I look? What do I do? I have never owned a diesel and am not familiar with them at all! Any help would be greatly appreciated. Thank you .
evelyn tremble is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 12-28-2005, 09:25 PM
BenzWorld Member
 
Date registered: Aug 2005
Vehicle: 1985 300 SD
Location: Houston, Texas & Temple, Texas
Posts: 290
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: engine won't stop!!

Thatis good. It will save wear and tear on your starter, keep your battery charged and will keep the engine and radiator from freezing. If garaged, it will also kill any rats or other vermin.

Your fuel economy will suffer, though. YMWNV

Your mileage will not vary.


Joe.

Quote:
evelyn tremble - 12/28/2005 10:17 PM
jbleaux is offline  
post #3 of 9 (permalink) Old 12-28-2005, 10:17 PM
BenzWorld Extremist
 
vwbuge's Avatar
 
Date registered: Aug 2002
Vehicle: 1985 300SD
Location: johnstown, pa
Posts: 831
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: engine won't stop!!

I am pretty sure you have a vacuum leak somewhere. Probably knocked a line off when replacing the starter.
vwbuge is offline  
post #4 of 9 (permalink) Old 12-28-2005, 10:34 PM
BenzWorld Member
 
Date registered: Aug 2005
Vehicle: 1985 300 SD
Location: Houston, Texas & Temple, Texas
Posts: 290
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: engine won't stop!!

Sorry for the flippant answer Evelyn.

For some reason, all I saw of your post was : "car won't stop". Now, I have seen the post in its entirety and I agree about a vacuum line being off.

Joe

Quote:
evelyn tremble - 12/28/2005 10:17 PM

Here is the problem[:O]. I recently acquired a 1984 190D. When I got the car it needed a new starter motor as the old one was shot and would not work. I put the stator motor in, not an easy task. Now the engine starts up fine but when I turn the key to turn the engine off it does not kill the engine…[:(!] I was told by the previous owner that the engine started and stopped fine before the startor motor went. I can remove the key and the engine keeps on running. Lucky it is a manual so I can stall it to kill the engine. Has anyone ever had such a problem? Where do I look? What do I do? I have never owned a diesel and am not familiar with them at all! Any help would be greatly appreciated. Thank you .
jbleaux is offline  
post #5 of 9 (permalink) Old 12-29-2005, 10:30 AM
BenzWorld Member
 
zaphodsplanet's Avatar
 
Date registered: Jun 2005
Vehicle: 04-E320 (benz #7)
Location: USA
Posts: 359
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Send a message via Yahoo to zaphodsplanet
RE: engine won't stop!!

Yes... I agree that you have a vacuum leak. Like the previous person said... the first place I would check would be around the starter. Look for hard plastic lines that may have come out of rubber lines. Check along the top of the engine too.... if someone wasn't careful in the repair they could have knocked off a line... or god forbid.... broke an old plastic part. I've had 2 300D's.... an 82 and an 83.... this was always something I ran into...good luck and let us know if you find the leak..

Jeffrey

Ops... almost forgot.... if you don't have one go and get a vacuum gauge... they have them for around $10-15 at most auto parts stores.... it will help you find the leak or bad vacuum element.
zaphodsplanet is offline  
post #6 of 9 (permalink) Old 12-29-2005, 07:10 PM
BenzWorld Member
 
benzboyz's Avatar
 
Date registered: Jun 2005
Vehicle: W124/230E, W202 C240 stationwagon, W210 E280 facelift
Posts: 366
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: engine won't stop!!

try to recheck the area when you install the starter you might accidentally remove some vacuum lines.
benzboyz is offline  
post #7 of 9 (permalink) Old 12-29-2005, 08:29 PM
BenzWorld Elite
 
tuttebenne's Avatar
 
Date registered: Jul 2005
Location: Long Island
Posts: 3,419
Mentioned: 3 Post(s)
Quoted: 215 Post(s)
RE: engine won't stop!!

You might be wondering why everyone is so concerned about vaccuum if the engine won't stop. The fuel distributor (the heart of a diesel) reguires a method that shuts off fuel in order to stop the engine. There is a vaccuum line that is routed to the ignition switch that allows vaccuum to flow to the fuel shut off diaphragm on the distributor. If you have a leak in the vaccuum system there will not be sufficient vaccum to shut of the engine. The 300D and 300E models use vaccuum to lock and unlock the doors; this is the most likely source of a leak in the 300s. I don't know if this is the same with your 190D but a simple vaccuum leak is a likely suspect. PS: there is a manual shut off on the throttle linkage indicated as a red "stop" sign on a flat tab of linkage - push this red tab and the fuel will manually be shut off. Best of luck and welcome to the forum.
tuttebenne is offline  
post #8 of 9 (permalink) Old 12-30-2005, 02:59 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2005
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: engine won't stop!!


Indeed vacuum hoses! I took off the air filter and found two vacuum hoses that where off. One was cut and the other one was off completely. Reattaching them has solved the not so mysterious mystery of the runaway engine....

Thank you to all of you who helped!
This forum is awesome.

HAPPY NEW YEAR!! to all out in Mercedes Land!

[:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)]
evelyn tremble is offline  
post #9 of 9 (permalink) Old 12-30-2005, 06:09 PM
BenzWorld Member
 
zaphodsplanet's Avatar
 
Date registered: Jun 2005
Vehicle: 04-E320 (benz #7)
Location: USA
Posts: 359
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Send a message via Yahoo to zaphodsplanet
RE: engine won't stop!!

Quote:
evelyn tremble - 12/30/2005 3:59 PM


Indeed vacuum hoses! I took off the air filter and found two vacuum hoses that where off. One was cut and the other one was off completely. Reattaching them has solved the not so mysterious mystery of the runaway engine....

Thank you to all of you who helped!
This forum is awesome.

HAPPY NEW YEAR!! to all out in Mercedes Land!

[:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)] [:)]
Totally Awesome Evelyn.... glad you found it.

Mission Accomplished....

Happy new year to you too....

Jeffrey
zaphodsplanet is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome