2-4 times after glow to start 300sd - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 12-05-2005, 09:48 PM Thread Starter
BenzWorld Newbie
 
Date registered: Dec 2005
Vehicle: 1992 400E
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Yahoo to longwaited
(Thread Starter)
2-4 times after glow to start 300sd

I have purchased my first mercedes, 1984 300sd. Every thing works great except when I try starting after glow light goes out. It has new battery and alternator. The problem does not happen every time, however sometimes I will have to turn the key off then wait for the glow light to go out and repeat this process sometimes 2-4 times. Every time I hear a click under the hood when this happens. It runs great when it does start. I would like to find out what the problem could be before I get stranded some where.
Thanks, longwaited [8D]
longwaited is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 12-06-2005, 06:18 AM
BenzWorld Elite
 
Date registered: Jan 2004
Vehicle: 1959 220S cabriolet, 1983 240D original owner, 1999 E300 turbo diesel, 1988 560SL, 2003 SLK320
Location: Ocean Isle Beach, NC
Posts: 3,495
Mentioned: 0 Post(s)
Quoted: 34 Post(s)
RE: 2-4 times after glow to start 300sd

Start by taking an ohm meter to the glow plugs. Good ones read 0.6 ohms cold.

Len
sokoloff is offline  
post #3 of 7 (permalink) Old 12-08-2005, 08:43 PM
BenzWorld Member
 
Date registered: Jun 2005
Vehicle: 2005 E320 cdi
Posts: 180
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 2-4 times after glow to start 300sd

I agree with sokoloff. Just because the glow plug light operates on the dash and you hear the relay click it doesn't mean that the plugs are functioning. They do wear out over time. I've experienced the same situation with volvo and audi diesels in the past!
junkman is offline  
 
post #4 of 7 (permalink) Old 12-10-2005, 12:53 AM Thread Starter
BenzWorld Newbie
 
Date registered: Dec 2005
Vehicle: 1992 400E
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Yahoo to longwaited
(Thread Starter)
RE: 2-4 times after glow to start 300sd

I may have not have ask my question correctly. When my glow light goes out and I turn the key the engine does not turn over, I have new glow plugs, When the glow plug light goes out and I turn the key all I hear is a click under the hud. This does not happen every time I try to start the car. This happens occasionally when the engine is cold or fully warmed engine. What should I check. Since this is my first mercedes, 84 300sd. I can compare the problem to a bendix problem on the starter on other cars I have owned. Is there a relay on an 84 300sd, before voltage is delivered to the starter ? If not should I have the starter checked out. I also have checked my ground, it is clean and grounded well.
I would appreciate any advise on this matter.
Thanks, longwaited
longwaited is offline  
post #5 of 7 (permalink) Old 12-10-2005, 03:31 AM
BenzWorld Member
 
benzboyz's Avatar
 
Date registered: Jun 2005
Vehicle: W124/230E, W202 C240 stationwagon, W210 E280 facelift
Posts: 366
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 2-4 times after glow to start 300sd

Maybe your solenoid switch on the starter itself has problem.
benzboyz is offline  
post #6 of 7 (permalink) Old 12-14-2005, 08:59 PM
BenzWorld Member
 
Date registered: Jun 2005
Vehicle: 2005 E320 cdi
Posts: 180
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 2-4 times after glow to start 300sd

Sorry-I got your PM but could not get the system to reply. I checked the oreilly's web site. Benzboy gave you some good advice. The solenoid is $17 bucks for your car. I'd change that first. If that doesn't fix the problem, have the starter tested. Oreilly's lists the starter motor for $79.00. i wish the parts for my 05 cdi were that cheap. Check the connections at the solenoid and starter as well. A loose wire will cause the same problem.
Hope that helps!
junkman is offline  
post #7 of 7 (permalink) Old 12-17-2005, 04:33 AM
BenzWorld Elite
 
84300DTurbo's Avatar
 
Date registered: Sep 2004
Vehicle: 1984 300D Turbo
Location: Mass.
Posts: 1,606
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 2-4 times after glow to start 300sd

this is a common phenomena. i have had it for years, but usually when the engine is hot. cycling the key switch has never failed to eventually engage the starter
so i live with it.
a new starter/solenoid has cured the problem permanently for others.
if you do go for a new starter go with an OE bosch rebuilt.
good luck with your new purchase they are great cars.










1984 300D Turbo - 231k.. son's car now... totalled 11/30/07 RIP

send lawyers, guns, & money...
84300DTurbo is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome