'99 E320 Intake Air Temperature Sensor MOD. Check Engine Light now. - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-28-2005, 12:34 AM Thread Starter
BenzWorld Newbie
 
Date registered: Nov 2005
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
'99 E320 Intake Air Temperature Sensor MOD. Check Engine Light now.

I have replaced a module from http://www.20horsepower.com/. Mercedes has 5 wires coming out of the IAT Sensor. The unit has 4 wires, 2 on each side of the unit. I have connected back 3 wires to their original wire and plugged the remaining2 wires to conenct to the mod unit. I thought I new with a voltmeter which was postive and which was negative. Everything seems to be running fine , except the increase in 20 HP, but I now have a "Check Engine" light on. I have pulled th battery cable to reset things. I just want to get rid of the check engine light... Does anyone know the colors codes of the wires? Which is + and which is -?
Any help is appreciated.[:(]
jdupree is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-29-2005, 03:53 PM
BenzWorld Elite
 
Check Codes's Avatar
 
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 31,634
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
RE: '99 E320 Intake Air Temperature Sensor MOD. Check Engine Light now.

Welcome to the forum.

I'd be very surprised if anyone is going to have the specialized knowledge you need.

My humble recommendation -- having been through things like this on other cars -- is to go back to the manufacturer that sold the thing; it's their responsibility to get it working properly.

Take care and enjoy the ride,
Greg
Check Codes is offline  
post #3 of 4 (permalink) Old 11-29-2005, 10:48 PM Thread Starter
BenzWorld Newbie
 
Date registered: Nov 2005
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: '99 E320 Intake Air Temperature Sensor MOD. Check Engine Light now.

Thanks for the reply and the advice.
jdupree is offline  
post #4 of 4 (permalink) Old 11-30-2005, 08:38 AM
BenzWorld Elite
 
Kirill's Avatar
 
Date registered: Jul 2003
Vehicle: 01 SLK 320 MT6
Location: Lake In The Hills,IL
Posts: 4,477
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: '99 E320 Intake Air Temperature Sensor MOD. Check Engine Light now.

Welll.... You got screwed - that thing nothing but 10 cents resistor. What it does is changes readings from MAF - your ECU found readings out of normal and turn CEL on.

My advice - get rid of that thing and revert to stock setup.

Kirill
Kirill is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome