ETS AND ABS LIGHTS - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 10-02-2005, 02:48 PM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2005
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
ETS AND ABS LIGHTS

Hey to all, I currently have a mercedes s280 1995 M-Reg,
Just really need some help if possible, When i am driving the car and turn a corner whilest breaking the ETS And ABS warning lights come on, Although this is not every time i turn the wheel whilest breaking, Once the lights come on the steering becomes very heavy and i have to stop the car turn it off and then re-start it and its fine, Does anyone phone what might be causing this problem?? I have also notice a strange feeling on the break pedel sometimes whilest breaking, Any help that you can offer would be great, You can e-mail adivice on

hardteen17uk@hotmail.com, or just post on here PLEASE
thanks keir
keir01 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 10-05-2005, 03:56 AM
BenzWorld Junior Member
 
Date registered: Aug 2005
Vehicle: Mercedes E220 CDi
Location: UNited Kingdom
Posts: 18
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: ETS AND ABS LIGHTS

This is a classic problem on later MB cars. I have had it on my 1998 C-Class and my 2001 E-Class and in both cases the solution was the same and simple. The brake light switch on these cars is a multi-function switch that controls the stop lights and the ABS/ESP system. If your model has a similar switch, try changing it first, it is cheap and easy to replace. My symptoms were - ABS/ESP warning lights suddenly comes on, ABS does not work, cruise control does not work. Switch off ignition and then re-start and problem has gone (for a while).
tamrsoft is offline  
post #3 of 5 (permalink) Old 10-24-2005, 06:06 AM
BenzWorld Elite
 
A1EK's Avatar
 
Date registered: Sep 2005
Vehicle: W208 CLK230K 2000 year, Past -W203 C Class, W202 C Class, W210 E Class, W201 190E
Location: Scotland
Posts: 1,399
Mentioned: 0 Post(s)
Quoted: 16 Post(s)
RE: ETS AND ABS LIGHTS

HI mate

I too have had the exactly the same thing happened to me. I have an E-Class W210 model and bothe the ABS and ETS lights on my dash have been coming on. Previously I had unplugged my ECU unit from the engine and checked the connector as it was missing a clip, I made sure it was secure and put it back into its housing. For about 3 months both light stayed off and I was happy once more thinking it was just down to the connector.!
However after three months the 2 dreaded ABS and ETS lights came on again. I checked the connector which was fine, but if I unplug the ECU and plugged it back in again the lights go out, but only for a while. The same thing if I turn off the ignition and then back on again for a bout 20mins the ligths stay off.
I am pretty sure it is not the physical ABS or ETS because if there was an immediate problem then the dash lights would show after a few secs when the car starts. When the lights are on the ABS, Traction and cruise control does not work. And whenthe lights are out the ABS, ETS and Cruise works fine.!

….please help!


18x235x40 (8.5J) & 18x255x35 (9.5J) Brabus Monoblocks VI reps, Eibach Pro lowering kit, no#1 pad front & rear, Rolled arches,20mm rear spacers/15mm front, Flat emblem, Kompressor skirt badges, Parking sensors, Colour coded grill, Front flat lip, Front eccentric camber bolts, Denso Irridium plugs, K&N filter, Sony ICE adapted to steering wheel buttons, Blue LED modified dash & interior.
][/B]
A1EK is offline  
post #4 of 5 (permalink) Old 12-10-2008, 11:10 PM
BenzWorld Newbie
 
Date registered: Dec 2008
Vehicle: 1999 Mercedes S320
Location: Dallas, TX
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I have exactly the same problem with my 1999 S320. Have had the brake light switch replaced twice, but to no avail. Has anyone resolved this issue yet?
jpstefan is offline  
post #5 of 5 (permalink) Old 12-11-2008, 04:05 AM
Outstanding Contributor
 
television's Avatar
 
Date registered: Sep 2005
Vehicle: 216 with everything. 2002 SL500 with everything. 2009 SL500 with everything.
Location: South coast .England
Posts: 6,543
Mentioned: 1 Post(s)
Quoted: 148 Post(s)
The brake light switch only mainly affects cars with ESP, and thats about 1997 on. What the faulty switch does is to kill the speed signal,,ETS is something else, but all of these things need a speed signal, so an easy thing is to check and clean up the speed sensors on the wheels

Malcolm

"I thought my vasectomy would keep my wife from getting pregnant but apparently it just changes the color of the baby."
television is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome