MAS Air Sensor - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 09-16-2005, 11:33 AM Thread Starter
BenzWorld Member
 
Date registered: Sep 2005
Vehicle: 1999 ML320
Location: Boston, MA
Posts: 72
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
MAS Air Sensor

Hello All, I'm new to this forum so I will apologize ahead of time if I am asking about something that has already been discussed but I need some instruction on how to change the Mass Air Flow Sensor on my 99 ML320. After geting a diagnosis from the dealer and an estimate for $600 I've decided to do it my self. It looks easy enough but I'm wondering about a post I came across that mentioned changing the air filter and resetting the CEL as part of the job. If the new air filter is necessary I can get one and put it in no problem but I am a little concerned about the reseting the CEL after installing the new MAS. I have no means of doing this. Is it necessary? Will it go off in its own once the problem is fixed or can I disconnect the battery? I'd like to avoid the dealer at all costs!
marc00 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-16-2005, 09:23 PM
Will Moderate For Cigars
 
cmitch's Avatar
 
Date registered: Apr 2005
Vehicle: 2002 ML320, 2005 S430 4MATIC, 2010 F150 Crew Cab
Location: City on the TN River
Posts: 10,691
Mentioned: 3 Post(s)
Quoted: 204 Post(s)
Lifetime Premium Member
RE: MAS Air Sensor

Check engine light will go off after 3 on-off start cycles on it's own. As far as instructions go, I'm in a good mood, so here goes.

1. Discontinue driving and park car on flat level surface.

2. Shut off ignition and exit car.

3. Open Hood.

4. Look to your left where the air filter box is located. Unsnap filter box.

5. With a screwdriver (phillips, I think) loosen the clamps that are holding on MAF.

6.Gently remove old MAF from each side of hoses and unplug the connector. Replace with new one and plug in connector.

7. Replace air filter with new one and snap the box back down in place.

Steps 1 and 2 must be performed but are JOKES!!

BTW, did the "stealer" include the cost of the ream cream in that $600.00?[:0]

Welcome aboard!!
cmitch is offline  
post #3 of 5 (permalink) Old 09-17-2005, 08:53 AM Thread Starter
BenzWorld Member
 
Date registered: Sep 2005
Vehicle: 1999 ML320
Location: Boston, MA
Posts: 72
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
RE: MAS Air Sensor

cmichprint, Thanks for the detailed instructions. I will print them out so I don't forget anything:)
I just cleaned the MAS with a little carb cleaner to see if that works before I buy the part. The engine is idling like crap at the moment, probably because I did not let it dry suficiently. I posted this question in an other forum and someone mentioned that I would need to turn the engine on & off twenty times to see the CEL go off if MAS actually fixed the problem. Does that sound right.
marc00 is offline  
post #4 of 5 (permalink) Old 09-17-2005, 09:02 PM
Will Moderate For Cigars
 
cmitch's Avatar
 
Date registered: Apr 2005
Vehicle: 2002 ML320, 2005 S430 4MATIC, 2010 F150 Crew Cab
Location: City on the TN River
Posts: 10,691
Mentioned: 3 Post(s)
Quoted: 204 Post(s)
Lifetime Premium Member
RE: MAS Air Sensor

It may take 20 on/off cycles if you do not drive the car. However, mine went off in only 3 because I drove it more than 15 minutes each time. I asked SA when I ordered mine and he said 3 on/off cycles with 15 minutes of driving each should clear it and it did. I've never tried the consecutive start and stop 20 times without driving to see if it would work.

As far as cleaning them goes, mine only lasted a few days and the CEL would come on again. I just replaced it about 8 months ago.

BTW, I understand some have been putting pre-oiled air filters on their cars. My mechanic convinced me this was tripe and to not do it! He said the oil could very well be the reason the failure rate on the MAF sensors is so high.
cmitch is offline  
post #5 of 5 (permalink) Old 09-19-2005, 11:52 PM
AMSOIL300CDT
Guest
 
Posts: n/a
Mentioned: Post(s)
Quoted: Post(s)
RE: MAS Air Sensor

thats just hype too...if something is designed to be harmless for the vehicles parts, then its HARMLESS..
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome