92 300te 4matic issues - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-15-2005, 07:44 AM Thread Starter
BenzWorld Newbie
 
Date registered: Aug 2005
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to JMacMillian
(Thread Starter)
92 300te 4matic issues

I think we've just gotten into a really bad deal. We bought this vehicle with 75,000 miles on it. I fear that all 75,000 miles were put on without maintenance. Especially as respects the 4matic option. We've replaced the transfer case, the whole breaking system and motor mounts and a bunch of other things and the vehicle still hiccups both in accelerating and cruising mode. Are we in for clutch and transmission repairs as a result of the lack of attention to the 4matic issues that were apparently not addressed? Thanks, Jerri
JMacMillian is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-15-2005, 02:38 PM
BenzWorld Elite
 
alexnatt's Avatar
 
Date registered: Feb 2004
Vehicle: 2000 e320 4matic
Location: Park City, Utah
Posts: 3,403
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
RE: 92 300te 4matic issues

search 4matic in the w124 forum
alexnatt is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome