2005 E320 CDI NIGHTMARE!!! - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 09-12-2005, 08:18 PM Thread Starter
BenzWorld Newbie
 
BNSNESS's Avatar
 
Date registered: Sep 2005
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
2005 E320 CDI NIGHTMARE!!!

I purchased a brand new 2005 E 320 CDI about a month ago and it has been nothing but trouble. Within a few days the car was "shuttering" when moderately accelerating between 15 and 20mph. I took it back to the dealer and was told it was because I was driving in the "comfort" mode and I should be driving in the "sport" mode. Not buying that, but trying it anyway, I took it back for a few days. No doubt within a few miles it starts again. I bring it back and they can find no diagnostic problem. I am told there is something wrong, but they don't know what it is. I tell them I don't want to be driving a car with a big question mark over it with a potential hazzard. They scratch their heads and then decide it needs all of the software reloaded. "Now" it's fixed they say and return the car. I warn them that if it happens again, it will be their car. Well, it does. Here's the clincher...they find me an exact brand new replacement and swap the cars out. You guessed it, same problem on this one! I bring the new one back and they now say they have the first vehicle fixed. They want me to test drive it for the day while they "fix" the "newer" car. They supposedly installed a new computer and everything is resolved. I take this vehicle for the day and it turns out being just as bad as it was previously.

I love the car and especially the gas mileage but what is up??? Anybody have any ideas?
BNSNESS is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 09-13-2005, 11:15 AM
BenzWorld Member
 
uberwgn's Avatar
 
Date registered: Jul 2005
Vehicle: 1998 E300D
Location: New England
Posts: 349
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 2005 E320 CDI NIGHTMARE!!!

there have been issues with these newest diesels. I have a friend in FL and they bought his back under Lemon Law. I don't think they ever determined the problem and they tied the car up for months...

1998 E300D
uberwgn is offline  
post #3 of 9 (permalink) Old 09-13-2005, 01:50 PM
BenzWorld Member
 
Pierre Louis's Avatar
 
Date registered: Apr 2005
Vehicle: 2005 E320 CDI
Posts: 92
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 2005 E320 CDI NIGHTMARE!!!

The guy in Florida is the ONLY fellow to document problems that I have heard of on 4 different boards that I hang out on. My inside information through a mechanic at Mercedes is that he was fooling around with an aftermarket computer chip that he kept removing when bringing it in for "problems" at the dealer.

As far as your "problem" with "hesitation between 15 and 20 mph," geez, this is a high performance diesel. That sounds normal for this car. I have the gasoline V6 in the ML320 and it is much smoother than the hot rod diesel at idle and at low RPM.

This dealer deserves a medal for trying to accomodate you. Keep them and be happy with your fantastic car.

Mine has 38,500 miles on it and runs great. You may get better low RPM driveability using premium diesel or a cetane booster, IMO.

Regards


2005 E320 CDI
1999 ML320
Previous: 1993 190E 2.3, 1992 320SE, 1987 260E, 1984 190E 2.3
Pierre Louis is offline  
post #4 of 9 (permalink) Old 09-13-2005, 03:15 PM Thread Starter
BenzWorld Newbie
 
BNSNESS's Avatar
 
Date registered: Sep 2005
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: 2005 E320 CDI NIGHTMARE!!!

P,

Sorry, but what is going on is not normal. Went for a drive today with service manager, shop supervisor, and regional tech sup and they all felt the problem. This is not a slight problem, but VERY noticeable. They agree something significantly wrong is taking place. They are now thinking something to do with ESP/throttle control. It is something that will soon show up in the repair manual for these new diesels I am certain. Once...call it a fluke, twice...call the engineers.
BNSNESS is offline  
post #5 of 9 (permalink) Old 09-13-2005, 06:14 PM
BenzWorld Member
 
Pierre Louis's Avatar
 
Date registered: Apr 2005
Vehicle: 2005 E320 CDI
Posts: 92
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 2005 E320 CDI NIGHTMARE!!!

Mine has never done that. Could it be the fuel? Diesel has a reputation in the US for being "rot-gut" at times.

Regards

2005 E320 CDI
1999 ML320
Previous: 1993 190E 2.3, 1992 320SE, 1987 260E, 1984 190E 2.3
Pierre Louis is offline  
post #6 of 9 (permalink) Old 09-13-2005, 07:06 PM Thread Starter
BenzWorld Newbie
 
BNSNESS's Avatar
 
Date registered: Sep 2005
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: 2005 E320 CDI NIGHTMARE!!!

Seems to be more mechanical. It is only at speeds b/w 15-30mph upon moderate acceleration. I don't think a fuel problem would be as specific and I have filled up at different stations. I hope to hear back from them tomorrow to see what they are coming up with.
BNSNESS is offline  
post #7 of 9 (permalink) Old 09-13-2005, 07:15 PM
BenzWorld Member
 
Date registered: Jun 2005
Vehicle: 2005 E320 cdi
Posts: 180
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 2005 E320 CDI NIGHTMARE!!!

What do you meen by shuttering? Is it a hesitation, an engine miss or a vibration in the drivetrain? I've had no major problems with my 05 cdi. Under hard acceleration sometimes you'll rev to the governor point before it shifts and give you a little turbo lag before it hits the next gear. Is that what you are experiencing?
junkman is offline  
post #8 of 9 (permalink) Old 09-13-2005, 07:49 PM Thread Starter
BenzWorld Newbie
 
BNSNESS's Avatar
 
Date registered: Sep 2005
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: 2005 E320 CDI NIGHTMARE!!!

No. I am speaking of something that feels something like when a car may be running out of gas and it is trying to go but can't. It is not a fuel issue though. It seems to be somehting deep in the "guts" of the transmission or some sort of computer relay that controls the throttle. I am no mechanic, but have spent a little time under the hood in the past and spoke with the techs a good bit. It is a very obvious "ugh, ugh, ugh, ugh" for lack of better description and lasts anywhere from 3-10 seconds.
BNSNESS is offline  
post #9 of 9 (permalink) Old 09-14-2005, 02:39 AM
BenzWorld Member
 
Pierre Louis's Avatar
 
Date registered: Apr 2005
Vehicle: 2005 E320 CDI
Posts: 92
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 2005 E320 CDI NIGHTMARE!!!

I have experienced this but only for a short time and for seconds. It only occurs when the throttle is barely on, such as coasting at low speeds. Since Katrina, I believe its the fuel quality since I have also noticed more knock at low RPM. It is fine now.

This can explain why two cars at the same dealer were doing it. Otherwise, a manufacturing defect in a part could do this, but European diesel is of much higher quality than in the US, so fuel related issues may be more likely.

2005 E320 CDI
1999 ML320
Previous: 1993 190E 2.3, 1992 320SE, 1987 260E, 1984 190E 2.3
Pierre Louis is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome