A/C on 1981 240D - Help! - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-29-2005, 05:28 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jun 2005
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
A/C on 1981 240D - Help!

Hi
I bought a very clean 1981 240D 4speed Manual two weeks ago and it was running fine until the A/C quit yesterday. Sudden death - it was working fine the day before and now the compressor does not switch on. Fan and everything else works fine, it just seems like whatever tells the compressor to switch on is not working. Any suggestions would be appreciated. Its pretty hot in California this time of year!!! [V][8D]
Alphatoto is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-29-2005, 07:35 PM
BenzWorld Elite
 
jdc1244's Avatar
 
Date registered: Jun 2003
Vehicle: 1991 300 SE
Location: Lakeland, Florida
Posts: 18,534
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: A/C on 1981 240D - Help!

Is the system fully charged?
jdc1244 is offline  
post #3 of 5 (permalink) Old 06-29-2005, 07:36 PM
BenzWorld Newbie
 
Date registered: Feb 2005
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: A/C on 1981 240D - Help!

First thing to check is the freon, that is if you have any in the system, next is the pressure switch on the dryer. use a voltmeter to see if it's getting any juice. after that someone else on here knows more than I.
gdemoss is offline  
post #4 of 5 (permalink) Old 06-30-2005, 08:16 AM
BenzWorld Member
 
benzboyz's Avatar
 
Date registered: Jun 2005
Vehicle: W124/230E, W202 C240 stationwagon, W210 E280 facelift
Posts: 366
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: A/C on 1981 240D - Help!

I agree with them, better check the refrigerant first, you can bridge the to cables on the filter drier tank, there are two sensors in it, one is the aux. fan, if you bridge this the fan will work, the other one if bridge the fan clutch should engage. if not maybe you have a proble with the temperatue sensor in the evaporator.
benzboyz is offline  
post #5 of 5 (permalink) Old 06-30-2005, 12:20 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jun 2005
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: A/C on 1981 240D - Help!

Thanks for the suggestions, I'll check the freon pressure but I think its a sensor. I'll be back![8)]
Alphatoto is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome