a/c question - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-07-2005, 07:34 PM Thread Starter
BenzWorld Junior Member
Date registered: Oct 2002
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
a/c question

My old reliable 1986 l90e air conditioner seems to have gotten a mind of its own. Unit is fully charged, compresser is not frozen, yet unit does not always go on when the ac button is hit. Sometimes it does sometimes not.

Could it be the relay (can you test this part?) What else could it be.

Is there a way to test if the compressor electromagent is getting l2 volts. Ie can I test to see if unit is getting power. There is a two wire electrical connection goeing to compressor. What are the two wires?

Any help appreciated.
tmryan is offline  
Sponsored Links
post #2 of 3 (permalink) Old 06-07-2005, 07:47 PM
BenzWorld Junior Member
Date registered: Jun 2005
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: a/c question

I am new to MB, but I've worked on VW's & BMW's and they are all a lot a like in technology.
check to see if the unit has a high/low pressure switch, it's usually mounted on the condensor I believe. It controls the a/c cycling on/off based on system pressure.
f5000sl is offline  
post #3 of 3 (permalink) Old 06-07-2005, 09:42 PM
BenzWorld Veteran
mjhawkins2346's Avatar
Date registered: Nov 2002
Vehicle: 10 GLK 350 4Matic
Location: Sonoma County CA
Posts: 694
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
RE: a/c question

Had a similar problem a few years ago.

Turned out to be the control unit assembly -- which is the assembly of relays and switches behind the panel on the cluster.

Good luck.


Now: 2010 GLK350 4Matic Then: 2003 C320 4Matic, 2006 E320 CDI, 2000 E320, 1994 E320, 1991 190E, 1985 300D, 1983 300D

"Eagles may soar, but weasels don't get sucked into jet engines."
mjhawkins2346 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome