Ejection problem? - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-30-2005, 04:26 PM Thread Starter
BenzWorld Member
billyons's Avatar
Date registered: Feb 2005
Vehicle: 2001 C320
Location: NoHo, CA
Posts: 247
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Ejection problem?

In my 2001 C320, I have the 6 disk cd changer and the navigation systems. The NAV sues the single disk player on the front of the console (see picture).

The manual says that I could also play audio cd's from the console player. And I did. The cd played great. The problem came when I tried to eject the disk from the console. The unit really worked at spitting out the disk, but it would not come out.

After pondering the situation for a moment, I came up with the idea of using 2 credit cards to pull the disk out of the deck like using tweezers. The method worked, but scratched the cd.

To this day I have not tried to put an audio cd into the console. And the NAV disks pop in and out without any trouble.

Has anyone else had this happen to them?
Attached Images
File Type: jpg 44_1497178_530200572621PM.jpg (37.5 KB, 40 views)

2001 Mercedes C320
2001 BMW 325i
1975 Dodge B200 w/ slant six
1960 Ford Ranchero
billyons is offline  
Sponsored Links
post #2 of 2 (permalink) Old 05-31-2005, 10:56 AM
BenzWorld Junior Member
Date registered: May 2005
Vehicle: CLK 430
Posts: 49
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to BenzBalla
RE: Ejection problem?

I had a similar problem with my navagation unit in a 2001 430CLK. I had just bought the car less than a month ago and had this problem. It appeared in mine just as it does yours the cloth material by the disc input had torn. I took it to my mercedes dealership b/c i had a 1 year warrenty. They ended up just replacing the whole thing for free. Would have cost 4000. I didn't find out what was causing it. But like I said my cloth had torn just as it appears to have torn in yours.
BenzBalla is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome