04 E320 AC problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-17-2005, 11:04 AM Thread Starter
BenzWorld Junior Member
Date registered: Apr 2005
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
04 E320 AC problem

My 04 E320's AC randomly stop working (no air) for about 1 or 2 minutes and then work again. The AC was on then no air but AC indication light are on. I tried turn it off and on couple times. Sometimes it worked and sometimes it didn't. If I leave it alone (while the problem occur) then it blow cool air again. Does anyone has this problem? My E320 only have 4500 miles on it. I will take it to the dealer today. Hopefully, they saw the problem before.
BTW, I did not have automatic option on at the time.

tyltan is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome