2001 ML320 - Locking System Malfunction - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-12-2005, 10:07 AM Thread Starter
BenzWorld Junior Member
Date registered: May 2005
Vehicle: '98 SLK 230
Location: Cupertino, CA USA
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Yahoo to Hernando
(Thread Starter)
2001 ML320 - Locking System Malfunction

I own a 2001 ML320 that has been trouble free . . . until now. I presently own two other Mercedes that are and have been excellent vehicles over a period of 19 years.

The 4 year warranty of the ML320 is about to expire and the dealership's service technicians do not have a clue as to what is causing the malfunction(s) of the remote locking system. The dealership has made 5 unsuccessful attempts at fixing the problem(s).

The malfunction is intermittent and can be described as follows:

1) Inability to lock the doors after the car is parked, the lights are off, seat belts off and the ignition key has been removed.

2) The interior chime (ignition and or seat belts warning signal) sounds off after opening the driver's door, the car is parked, the lights are off, seat belts off and the ignition key has been removed. The vehicle cannot be locked with the remotes.

3) After driving the car back home from the dealership, the doors were locked with the remote. Moments later we tried to unlock the doors and the remotes (2) would not unlock the doors. The dealership advisor told us over the phone to unlock the doors using the key (not the remote). When this was done, the door unlocked but the theft alarm was set off by itself and turned silent only when it timed out.

The dealer has replaced the driver door jam switch, the ignition switch, driver's door latch assembly and the ignition key tumbler.

My next move is to setup a meeting with the Dealership's Service Director, the Service Advisor and a Mercedes Benz Representative.

If anybody has any good suggestions as to the cause and solution of the problems, please let me know. Please post your replies to these newsgroups and to my e-mail address.
Hernando is offline  
Sponsored Links
post #2 of 2 (permalink) Old 05-13-2005, 04:12 PM
BenzWorld Member
5thMB1stNew's Avatar
Date registered: Nov 2002
Vehicle: '82 380SL+'02 ML320
Location: Portsmouth VA
Posts: 188
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 2001 ML320 - Locking System Malfunction

Similar issues twice on my '02 ML320. I am no tech, but I do recall that faults were recorded between the ignition switch and a circuit board. Though it happened twice, my SA swore that they were independent and all fault codes were recorded in system memory (or however they say it). Warranty item all the way, and not infrequent.

On a side note, I went on MB Owner online to find the exact fix, rather than hunt down the service record in my world reknown filing system. What a waste of time! I foolishly thought my service history would be available, but all you can do is update maintenance and schedule more. [xx(]

1974 280 (gone)
1982 380SL (schwarzekatz)
1984 300TDT (why did I get rid of the best one?)
1992 300E (gone and forgotten)
1993 190E (daughter drives)
1994 E320 Wagon (gone and forgotten)
2002 ML320 (thank goodness for extended warranty)
5thMB1stNew is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome