Vito 108CDI problem URGENT - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-03-2005, 04:37 AM Thread Starter
BenzWorld Junior Member
Date registered: Nov 2004
Location: Serbia and Montenegro
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Vito 108CDI problem URGENT

I have terrible problem with VITO 108CDI production 1999Y

Engine works OK,when I accelerate slowly it goes normaly,but when I stronlgy
push gas,I want to accelerate quick engine shut off,it all happens about 3000rmp and higher

I have tried all kinds of diagnosis StarDiagnose,Mercedes hht and carsoft but there are no errors

Also I have noticed something else,when vehicle stands in place and I push gas it only goes
to 3000rpm, but then vehicle is in move it goes to 4500 rpm

Help me please ,what sensors to check ,change what to do???

webwizard is offline  
Sponsored Links
post #2 of 2 (permalink) Old 10-24-2005, 02:02 PM
BenzWorld Newbie
Date registered: Oct 2005
Vehicle: VITO - 112 CDI 1999
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to Runson
RE: Vito 108CDI problem URGENT

Fixed this one?
Runson is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome