Mercedes 300 E 1993 - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-22-2005, 11:47 AM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2005
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Mercedes 300 E 1993

Hi, i have a 1993 Mercedes 300E 2.8 Liter. I love my car and I have decided to finally do some of the very necesary work on it. There are a lot of non mechanical things stereo, driver window, mirror, etc, which I will do in a few weeks. But my main concern right now is the engine. About two years ago it started doing this thing where sometimes when i pushed the gas, it sounded like it imediately started running on 5 cyclinders becuase it became ruff, and had no power at all. If i continued to floor it after a few seconds, it would kick in and light up the street. It went on for about 6 months and I had no time to fix, and then it went away on its own. But recently it has reapeared. I haven't replace the plugs, wires, or cap, since 66,000 and now it has 173,000 so that was my first thought. Any ideas, I also read from another post with someone having a similar problem that he soaked his Idle control valve and that did the trick. Please help. Thanks
mortymower is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome