Mercedes versus BMW - Page 4 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #31 of 32 (permalink) Old 05-23-2005, 06:52 AM
BenzWorld Junior Member
Date registered: May 2005
Vehicle: 1996 C36 AMG
Location: Cape Coral
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: Mercedes versus BMW

I have a 1996 C36 now. I love it. I used to drive a 1990 BMW 535I It always had problems. but I really can't compare them because of the years. But I would never consider to buy another BMW again, I'll stick with the MB.
C36 AMG is offline  
Sponsored Links
post #32 of 32 (permalink) Old 05-27-2005, 05:05 PM
BenzWorld Elite
Storm's Avatar
Date registered: Jan 2004
Location: Islamabad, PK
Posts: 4,115
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: Mercedes versus BMW

That's funny, I'm tempted to move the other way, seems like MB/DC standards are fading fast....
Storm is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome