Turn signals - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-17-2005, 05:31 PM Thread Starter
BenzWorld Elite
Syracuse315's Avatar
Date registered: Jan 2005
Vehicle: '86 190E 2.3L
Location: Syracuse, NY
Posts: 1,724
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Turn signals

I just got done installing clear corners on my 86 190E. When i turned the car on and tried using the blinkes they didnt work..i unplugged the turn left blinker, and the right one worked. after taking the 3 metal plugs out of the black holder( the thing that plugs into the back of the light, both turn signals dont work...and theres not even the ticking noise and the green arrow on the dash anymore. got any hints?
Syracuse315 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome