Electrical Problem in 560 SL - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-09-2004, 09:20 AM Thread Starter
BenzWorld Newbie
 
Date registered: Dec 2004
Location: Sacramento, California
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Electrical Problem in 560 SL

This morning, my '86 560 sl had no power to the instruments, the power windows, turn signals and, I'm afraid, no brake lights. Heater blower worked as did headlights. I'm suspecting something otehr than a fuse, because of the power windows. Any suggestions where to start looking?

Thanks.

Fred Dial
Fred Dial is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-13-2004, 12:44 PM Thread Starter
BenzWorld Newbie
 
Date registered: Dec 2004
Location: Sacramento, California
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: Electrical Problem in 560 SL

Never mind. I found it. It WAS a fuse. The fuse ontrolled the window relay, in addition to those other things.
Fred Dial is offline  
post #3 of 3 (permalink) Old 12-14-2004, 10:19 AM
BenzWorld Elite
 
Date registered: Dec 2002
Vehicle: 92 500SEL to 01 E320T and others
Location: Florida
Posts: 3,886
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
RE: Electrical Problem in 560 SL

Those fuses were prone to corrosion also!
Peter Guenther is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome