300sd fuel system problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-26-2004, 06:51 AM Thread Starter
BenzWorld Newbie
Date registered: Nov 2004
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
300sd fuel system problem

I need some help here in diagnosis. I really do not want to buy all new parts, so i need to narrow it down.
the symptoms are long deiseling after ignition shutoff. Somtimes she needs to be primed with the pump to start after the deiseling. Also after she goes below half a tank usally, she will lose power in her running ability,and the pedal will have to be pumped vigorsly to get her going.she does not stall or die when this happens, it just seems like the fuel flow stops or slows.I am torn between a new pump,a shutoff valve ,or a injection pump.She has new filters and about 225,000 on her. please help the old girl!
cajuncody372 is offline  
Sponsored Links
post #2 of 4 (permalink) Old 11-27-2004, 10:15 AM
BenzWorld Member
Date registered: Dec 2003
Vehicle: 2002 CL 500
Location: west palm beach fl.
Posts: 222
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 300sd fuel system problem

you can have your injector pump rebuilt or get a rebuilt one, fuel shut off vave is electric you can observe it working when you close ignition switch it's either on or off, also fuel injectors could be dirty and dribbling gas instead of fine spraying it.good luck
reliablebruce is offline  
post #3 of 4 (permalink) Old 11-27-2004, 02:14 PM
BenzWorld Veteran
Date registered: Sep 2004
Vehicle: 1982 300SD
Location: Bel AIr, MD
Posts: 692
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 300sd fuel system problem

I would think you might have two problems. The no shut off with the key--on a diesel ( it is an SD, right?) is often due to low vacumm. The diesel shutoff is vacuum controlled , if you have a leak, or if the vacuum pump is weak the shutoff might not work. Its OK for an SD to diesel :)
As for the fuel delivery issues, I suspect a clogged inlet screen in the tank--or a clogged filter. You could even have algae in the tank leading to the clogging of the inlet screen.
Do the cheap and easy stuff first.
MS Fowler is offline  
post #4 of 4 (permalink) Old 11-28-2004, 06:25 AM
Posts: n/a
Mentioned: Post(s)
Quoted: Post(s)
RE: 300sd fuel system problem

I can assume you have the 617 turbo

One problem area could be the primer
If you have the old style one it
can leak.
If it leaks heavily when pumping
you probably have air entering the
fuel system when you go to drive off.
If the leak is bad enough you will have
air being sucked in thus reducing the
amount of fuel going to the injectors
and into the engine.
= no power.

Also, as mentioned before, remove the
fuel tank screen and clean it up well.
It could be clogged.
Less fuel=less power.

The dieseling is most likely a vacuum
Check the vacuum lines.
You might have knocked one loose when
replacing the oil filter(happens all the time).
If not buy some golf T's and plug the line
going to the door locks.(should have a yellow
plastic valve on it)
Also check the brown vacuum line.
Oil can enter and block the lines=new shut off valve.(Cheap but a PIT to replace)

You can also do a search on this site for
"fuel tank screen", and "Shut off valve".

PS: Did the search for you.

Info on tank screen.


Info on shut-off valve.


Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome