When I hit the brake. I heard tick, tick ,tick noise. - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-30-2004, 06:57 PM   #1 (permalink)
BenzWorld Junior Member
 
Date registered: Oct 2004
Vehicle: 89 300 CE
Posts: 16
When I hit the brake. I heard tick, tick ,tick noise.

When the car is coming to stop sign, I hit the brake, I heard tick, tick, tick noise right in front of me. When my foot off the brake, the noise gone. What is the problem???
new kid is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-30-2004, 08:17 PM   #2 (permalink)
BenzWorld Member
 
Date registered: Sep 2004
Posts: 84
RE: When I hit the brake. I heard tick, tick ,tick noise.

what kind of car? mileage? brakes replaced any time this century? windows up or down?
benztech1209 is offline   Reply With Quote
Old 10-30-2004, 08:42 PM   #3 (permalink)
BenzWorld Elite
 
mzsmbs's Avatar
 
Date registered: Sep 2004
Vehicle: 1972 Mercedes 250 (/8) W114/M130
Location: on a high bank of a creek
Posts: 7,299
RE: When I hit the brake. I heard tick, tick ,tick noise.

maybe your motosaurus is starting to limp?
__________________


in political asylum
mzsmbs is offline   Reply With Quote
Old 10-31-2004, 05:42 AM   #4 (permalink)
BenzWorld Member
 
Date registered: Dec 2003
Vehicle: 2002 CL 500
Location: west palm beach fl.
Posts: 222
RE: When I hit the brake. I heard tick, tick ,tick noise.

please lets keep this a MB forum and not stain it with todays filthy politics.
reliablebruce is offline   Reply With Quote
Old 10-31-2004, 01:18 PM   #5 (permalink)
BenzWorld Junior Member
 
Date registered: Oct 2004
Vehicle: 89 300 CE
Posts: 16
RE: When I hit the brake. I heard tick, tick ,tick noise.

It is 89 300 ce, 120000 miles, front brake service in May,2004. window up & down no problem. Thanks.
new kid is offline   Reply With Quote
Old 11-01-2004, 08:37 AM   #6 (permalink)
BenzWorld Member
 
Date registered: Dec 2003
Vehicle: 2002 CL 500
Location: west palm beach fl.
Posts: 222
RE: When I hit the brake. I heard tick, tick ,tick noise.

I got this problem too but just had car in shop brakes are fine. if it's not worn pads or the wear indicator, maybe the grease or compound they put on the pads to quite them has now worn off. this is just a theory maybe benztech can help. good luck.
reliablebruce is offline   Reply With Quote
Old 11-02-2004, 04:23 AM   #7 (permalink)
BenzWorld Elite
 
mzsmbs's Avatar
 
Date registered: Sep 2004
Vehicle: 1972 Mercedes 250 (/8) W114/M130
Location: on a high bank of a creek
Posts: 7,299
RE: When I hit the brake. I heard tick, tick ,tick noise.

Quote:
reliablebruce - 11/1/2004 10:37 AM

I got this problem too but just had car in shop brakes are fine. if it's not worn pads or the wear indicator, maybe the grease or compound they put on the pads to quite them has now worn off. this is just a theory maybe benztech can help. good luck.
could be. that stuff doesn't wear off though. could be that your rotors are out of round and just make that noise... it also possibly could be shims that are getting thin or are missing... check for stones or some other road grime that maybe cought in there...

worse case it could also be some of the stearing components getting worn...
mzsmbs is offline   Reply With Quote
Old 11-05-2004, 03:57 PM   #8 (permalink)
BenzWorld Member
 
Date registered: Dec 2003
Vehicle: 2002 CL 500
Location: west palm beach fl.
Posts: 222
RE: When I hit the brake. I heard tick, tick ,tick noise.

got my cl out of MB shop today, no more brake ticking noise. it was the retaining springs on the front brakes that got worn and where rubbing on the rotors no big problem they just replaced the srings and pin.
reliablebruce is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 04:08 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.