1984 380 SE--Acceleration problems, hard shifting - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-24-2004, 04:29 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2004
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to IMnotDAVIDxnsx
(Thread Starter)
1984 380 SE--Acceleration problems, hard shifting

This problem is intermittent. When it first began to develop, almost a year ago, the car would run fine at a dead start in the cold moring, but would bog down as the car warmed up. Since then, the idle control valve, spark plugs, vacuum advance, fuel injector seals, catalytic converter (pre and plain ol' cat), and fuel distributor have all been replaced in an attempt to solve this problem. Currently, the car acts bogged down 98% of the time. The other 2%, only moderately bogged. It no longer changes depending on morning or afternoon (but the fact that it's summer could have something to do with that.) You can be depressing the gas pedal at 30 degrees, for example, and keep it there--the car will crawl and then pick up horsepower at a random point during the acceleration. Sometimes, the pick up in horsepower is immediately followed by a car shuddering and teeth clenching shift up into the next gear. Any suggestions? So much money has gone into this problem. I am about to give up. I will be happy to answer any other questions about the car if need be to help diagnose.

-david
IMnotDAVIDxnsx is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-24-2004, 07:40 AM
BenzWorld Member
 
Date registered: Dec 2003
Vehicle: 2002 CL 500
Location: west palm beach fl.
Posts: 222
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 1984 380 SE--Acceleration problems, hard shifting

just a shot in the dark, but do you think it could be a failing fuel pump? don't know if you had this checked but it would cause all those symptoms. how is the fuel filter? could also be ignition timing problem good luck.
reliablebruce is offline  
post #3 of 5 (permalink) Old 08-24-2004, 09:45 AM
Guest
Guest
 
Posts: n/a
Mentioned: Post(s)
Quoted: Post(s)
RE: 1984 380 SE--Acceleration problems, hard shifting

Hi David.

Have you checked the engine timing?

It sounds alot like what my Camry used
to do,but while slowing down for any reason,
and then hitting the gas again while the car was still moving, would make it bog down.

Mine was the timing.
I had changed the timing belt and the belt
had jumped a tooth.
Putting it back the right way fixed my problem.

So,if the timing wasn't checked I would do so
ASAP.

What about the cap, rotor and spark plug wires?
Have they been replaced?
How do your battery cables look like?
Corroded,clean,chaffing?


As to the shifting that to should return to
normal once the problem is fixed.
Since the engine generates vacuum and the
tranny is vacuum assisted, the way the engine
is running now it won't generate enough vacuum
thus the tranny problem.

Hope this helps.

Louis.
post #4 of 5 (permalink) Old 08-24-2004, 09:51 AM
BenzWorld Elite
 
teky's Avatar
 
Date registered: Jun 2004
Vehicle: chris
Location: uk north east region
Posts: 1,790
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 1984 380 SE--Acceleration problems, hard shifting

do a compression test it could also be worn valves and or lobes on the cam, timing is a real good one and also filter, is the top end tapety like the valves need resetting all these will cause lack of power
teky is offline  
post #5 of 5 (permalink) Old 08-25-2004, 01:40 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2004
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to IMnotDAVIDxnsx
(Thread Starter)
RE: 1984 380 SE--Acceleration problems, hard shifting

oh yes, i completely forgot--the fuel pump has also been switched out to a more heavy duty after-market one for that year.
IMnotDAVIDxnsx is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome