Desperate for electrical fix - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-24-2004, 02:20 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2004
Vehicle: 98 C230k
Location: Dorset, England, GB
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Desperate for electrical fix


I have a 98 230k c class with intermitant front window failure, which is driving me mad!! the windows keep failing to operate, if I disconect the battery for a few minutes they will work again, but after a few hours or days thay fail again. Sometimes it may be only one window but today after resetting them this morning after disconnecting the battery, both have failed again this afternoon.
Can anyone help or car will have to go!
timbo is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-24-2004, 02:57 PM
BenzWorld Junior Member
 
Date registered: Jul 2004
Vehicle: W203
Location: England UK
Posts: 48
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: Desperate for electrical fix

Quote:
timbo - 7/25/2004 9:20 PM


I have a 98 230k c class with intermitant front window failure, which is driving me mad!! the windows keep failing to operate, if I disconect the battery for a few minutes they will work again, but after a few hours or days thay fail again. Sometimes it may be only one window but today after resetting them this morning after disconnecting the battery, both have failed again this afternoon.
Can anyone help or car will have to go!
If you have been disconnecting your Battery the Windows may require resetting.

try this....

Lower each window a little and then close using the first button position and keep the button pressed until you hear a click in each door, in turn. Takes about 2-3 seconds per window, the same with the sunroof if you have one.

Joe

Joe_Barton is offline  
post #3 of 7 (permalink) Old 07-25-2004, 11:39 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2004
Vehicle: 98 C230k
Location: Dorset, England, GB
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: Desperate for electrical fix

cheers Joe, yeh, been there done that, its the total failure that's the problem, even if you don't reset them they still work, mine don't when the fault occurs.

Thanks, Timbo
timbo is offline  
post #4 of 7 (permalink) Old 07-25-2004, 12:58 PM
BenzWorld Elite
 
teky's Avatar
 
Date registered: Jun 2004
Vehicle: chris
Location: uk north east region
Posts: 1,790
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: Desperate for electrical fix

it could be a faulty window control module it might be overheating
http://www.benzworld.org/publications/pub.asp?id=267
teky is offline  
post #5 of 7 (permalink) Old 07-26-2004, 06:26 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2004
Vehicle: 98 C230k
Location: Dorset, England, GB
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: Desperate for electrical fix

Thanks Teky that sounds like the place to start, unfortunately the manual sheets I printed from your link arn't clear enough for me to read, even with my glasses on. Can you tell where to look for the window control module?

Regards, Timbo
timbo is offline  
post #6 of 7 (permalink) Old 07-26-2004, 12:50 PM
BenzWorld Elite
 
teky's Avatar
 
Date registered: Jun 2004
Vehicle: chris
Location: uk north east region
Posts: 1,790
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: Desperate for electrical fix

white dot item 2 page 129, in the trunk passanger side usa behind the carpet
teky is offline  
post #7 of 7 (permalink) Old 07-29-2004, 02:09 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2004
Vehicle: 98 C230k
Location: Dorset, England, GB
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: Desperate for electrical fix

Hi Teky,

can't see any module in the booy/trunk, thare is a relay near the fuse box and a white plastic box by the jack. As I don't have a manual i can't check out the pages you quoted.
Maybe mine is an early 98? I vivited the dealership yesterday and a very helpfull mechanis there said they had had a similar problem with another c class and the fault was in the switch block around the gear selector, what do you think?

Regards, Timbo
timbo is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome