99 C43 CD Changer problem... - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-18-2004, 11:48 AM Thread Starter
Premium Member
 
Date registered: Jul 2004
Vehicle: 1999 C43, 2002 ML55, 2005 C230 Kompressor, 1994 E320 Wagon, 1949 Ford Convertible (Dad orig ownr)
Location: Fairhope, Alabama
Posts: 38
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Premium Member
Send a message via Skype™ to deezee
(Thread Starter)
99 C43 CD Changer problem...

I have a 99 C43 with 87k miles. Last week I got an error when trying to access the CD, it says "no CD changer". I removed the unit, and re-set the power cable and the fiber optic connection.
- I wiped the optic cable clean but it is still not recognizing the cd. After I did this, it came up on disk 6 like it was going to work and then just switched back to the radio.

- When you try to remove the magazine by pushing the eject button, it flashes green for about 20 seconds and nothing happens.

- I can see the #6 cd is still engaged in the unit and it won't release it when I press the eject button
deezee is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-19-2004, 04:49 AM
BenzWorld Veteran
 
Date registered: Oct 2003
Vehicle: CL500, E430, SLK, Subaru...
Location: London
Posts: 648
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 99 C43 CD Changer problem...

I know this isn't a real answer, but consider ditching a CD changer anyway,and get a head unit which runs with MP3 CDs. You can fit a whole changer's worth of music into a single CD when you MP3 encode the music, and then you aren't risking your precious CD collection a-bumpin and a-bangin in the car...

Steve
London, right in the middle
03 CL500 (Black/Grey, 48k, Comand, 7GTronic, Keyless Go) 302 Bhp
01 E430 (Silver/Black, 112k, Comand, Lingua, 7 seats, tow...) 275 Bhp
97 SLK (40k, Yellowstone, partner's car!) 200 Bhp
03 A210 AMG (Black/Black, 63k, project rescue car) 140 Bhp

...I make that 917 Bhp...!
LondonThing is offline  
post #3 of 4 (permalink) Old 07-19-2004, 08:22 PM Thread Starter
Premium Member
 
Date registered: Jul 2004
Vehicle: 1999 C43, 2002 ML55, 2005 C230 Kompressor, 1994 E320 Wagon, 1949 Ford Convertible (Dad orig ownr)
Location: Fairhope, Alabama
Posts: 38
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Premium Member
Send a message via Skype™ to deezee
(Thread Starter)
RE: 99 C43 CD Changer problem...

Thanks, I will definitely do that once I determine the changer is toast. What brand looks good in the car, I worry about a cheap-looking receiver in the Benz.
deezee is offline  
post #4 of 4 (permalink) Old 07-20-2004, 07:00 AM
BenzWorld Veteran
 
Date registered: Oct 2003
Vehicle: CL500, E430, SLK, Subaru...
Location: London
Posts: 648
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 99 C43 CD Changer problem...

It really depends on your existing trim. I bought a Sony - I forget the model number now the car has gone to drjan, but it's a silver front with two deceptive looking traditional rotary controls, at either end of the fascia. I went for this because it doesn't look too modern to the casual thief, and doesn't sit badly in the imitation Carbon Fibre fascia of the '43. My only real complaint with the unit is that it doesn't handle inter-track crossfades at all - otherwise it's superb.

I've been hunting for a replacement unit for the E55 now the 43 has gone (sob!) and there's a few vendors in the US who are advertising into the UK market; if you hunt on EBay for "Sony MP3 Car" you will most likely find them. I'm not gonna biy from them though - why would I be stupid enough to close out a 'bargain' which then hits me for $70 in shipping and a risk of a further 20% or so in import tax? D'oh!

Steve
London, right in the middle
03 CL500 (Black/Grey, 48k, Comand, 7GTronic, Keyless Go) 302 Bhp
01 E430 (Silver/Black, 112k, Comand, Lingua, 7 seats, tow...) 275 Bhp
97 SLK (40k, Yellowstone, partner's car!) 200 Bhp
03 A210 AMG (Black/Black, 63k, project rescue car) 140 Bhp

...I make that 917 Bhp...!
LondonThing is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome