Trouble installing new stereo on 190E - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-09-2004, 10:15 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2004
Vehicle: MB 190E 2.6
Location: West USA
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Trouble installing new stereo on 190E

Hi every one. I have been visiting this forum a lot and this is my first post =).

Well I have 190E 2.6 1992 and I'm trying to install a new stereo in to it. Previous owner didn't do a good job installing it because the back speaker are not working and every time I accidently click on the Hazard Light switch the whole system shut off for a while.

I was hoping if any one have a wiring diagrams that could e-mail it to me or if any one know where can I find installation kits and harness for this vehicle.

Thank you for your time. =)

Paul J.
suzuki750 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome