1989 420 SEL - Acceleration problem when warm - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-30-2004, 01:25 PM Thread Starter
BenzWorld Junior Member
 
sali's Avatar
 
Date registered: May 2004
Vehicle: 1989 420SEL
Location: Houston, TX
Posts: 49
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1989 420 SEL - Acceleration problem when warm

This problem only occurs when my car has been parked for an hour or so with the engine warm. I start it, put it in gear, and the car hesitates and acts like it is about to stall before accelerating. I have a reputable trusted mechanic who ran all sorts of tests, replaced the oxygen sensor and all 8 new injectors, same problem. The scope / analyzer does not show anything wrong. He says that any rotor or spark plug issues would have showed up on the scope.

Any suggestions or advice is greatly appreciated.
sali is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-31-2004, 03:37 AM
BenzWorld Elite
 
shrimpton's Avatar
 
Date registered: Aug 2002
Vehicle: '90 560SEL, V8 Landcruiser, Toyota S/Wagon
Location: Christchurch, New Zealand
Posts: 2,552
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Your car is a W126 model, go to the W126 forum....

....and ask questions about your car. I personally can't help,but heaps of guys on the W126 forum will be only too happy to assist.
shrimpton is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome