Audio 10 with no light - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-29-2004, 01:35 PM Thread Starter
PET
BenzWorld Junior Member
 
Date registered: May 2004
Vehicle: 00 C-200 Kompressor
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Audio 10 with no light

I've got an MB Audio 10 CD radio, works realyy good, but the display doesn't light. Is that some setting problem or what?
PET is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-01-2004, 12:26 AM
BenzWorld Veteran
 
n5160u's Avatar
 
Date registered: Apr 2004
Vehicle: 2000 Designo SLK-05 C230WK-05 E320CDi-2010 GLK 350
Location: Hayweird, CA
Posts: 714
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: Audio 10 with no light

If the rest of the radio's control panel is backlighted and the lights follow the panel dimmer control it is likely the light bulb for the LCD is burned out. Running the panel lights at full brightness really shortens the life of the sub-minature lamps in radios. That is why when you look at any VW built since 98 it has blue and red panel lighting. The entire dash and panel lighting is done by LED's because they do not fail nearly as often regardless of the brightness setting.

The down side of that approach though is that there is no way to control the panel lights on an aftermarket radio or HU because the panel brightness is controlled by a CAN BUS signal along with the other commands that turn the radio and amps on and off and report DTC's from the amps and speakers.

Most electronic supply stores do not stock the small lights used in radio panels but they can be found in larger hobby stores that stock minature lamps for model railroad applications. The lamp is a pain in the a** to get to but you will find it clipped to the edge of the LCD panel because it is configured to edge light the display rather than light it from behind. Don't even try to replace it unless you are comfortable using a soldering iron in confined spaces.

Potato Chip, custom canuter valve, low-friction muffler bearings, synthetic turn signal fluid, Hi-Definition Progressive Scan Wiper Blades.
Law-makers are supposed to regulate in the interest of the public as opposed to regulating in the interest of the regulated party.
If it says Pratt and Whitney on the outside it better say Martin Baker on the inside.
n5160u is offline  
post #3 of 4 (permalink) Old 06-01-2004, 05:10 AM Thread Starter
PET
BenzWorld Junior Member
 
Date registered: May 2004
Vehicle: 00 C-200 Kompressor
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: Audio 10 with no light

Thanks N5160U
PET is offline  
post #4 of 4 (permalink) Old 06-01-2004, 07:26 AM Thread Starter
PET
BenzWorld Junior Member
 
Date registered: May 2004
Vehicle: 00 C-200 Kompressor
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: Audio 10 with no light

Next problem! I try to remove the radio, put two sticks into holes, can hear that it unlocks, but nothing to grasp to pull out the radio. Anybody has experience, advice?
PET is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome