Need some expert help ...(again) - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-22-2004, 11:32 AM Thread Starter
BenzWorld Junior Member
Date registered: Apr 2004
Vehicle: 1990 500SL -128K
Location: Pennsylvania
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to gates
(Thread Starter)
Need some expert help ...(again)

I received some real good step by step instructions to remove the inst cluster. It Worked. Unfortunatley, now inst cluster doen't light up at night. Not sure what to do?
I have paged through and read numerous posts on cluster and how gauges jump. My fuel, MPG, and maybe a few others jump whenevr I use the turn signal. I read to fix you need to re-solder...could someone give me more info.
Thanks from sunny Pennsylvania...
gates is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome