ML63 2008 code0732 - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 01-28-2017, 10:09 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2012
Vehicle: 2005 CLK320, 2005 C230
Location: Vancouver, WA
Posts: 14
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
ML63 2008 code0732

Hello all,
I just purchased a 2008 ML63 that was a local Oregon vehicle with a excellent dealer service history and 95K miles. It is in amazing condition and runs and drives well. two weeks ago it was serviced and had no issues. A check engine light came on and it is Fault 0732. Now the dealer is recommending a $9,000.00 service replacing the camshafts and related parts due to low compression. is this normal for the 6.3? Just wondering if anyone else has experienced this issue. I attached the document from the dealer.
Attached Files
File Type: pdf Action Plan.pdf (401.2 KB, 29 views)
allwheeldrive is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 01-28-2017, 10:17 AM
BenzWorld Junior Member
 
Date registered: Jan 2017
Posts: 24
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
i think you dealer is full of crap to be honest with you. the camshaft wouldn't affect compression in the engine. the valve would have to be hung open or cylinder wear of some sort. Another question is why are they replacing the head boths if they arent removing the heads. sounds like a waste of money there to me. i would definetly get a second opinion on the vehicle before spending that kind of money on it. i am a mercedes benz technician and will look linto the code and see what i can find out.
buggwuggy2017 is offline  
post #3 of 8 (permalink) Old 01-28-2017, 10:23 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2012
Vehicle: 2005 CLK320, 2005 C230
Location: Vancouver, WA
Posts: 14
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
Thanks,
I was doing a little research and found a class action lawsuit about this issue. The camshafts were to soft and had premature failure. I will take it to a independent shop and get another opinion. The "action plan" was for the previous owner. Something smells fishy I'll admit. Have you ever done this job?
allwheeldrive is offline  
 
post #4 of 8 (permalink) Old 01-28-2017, 10:27 AM
BenzWorld Junior Member
 
Date registered: Jan 2017
Posts: 24
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Quote:
Originally Posted by allwheeldrive View Post
Thanks,
I was doing a little research and found a class action lawsuit about this issue. The camshafts were to soft and had premature failure. I will take it to a independent shop and get another opinion. The "action plan" was for the previous owner. Something smells fishy I'll admit. Have you ever done this job?


i looked up the cault code P0732 and found this link


https://www.engine-codes.com/p0732_mercedes-benz.html


i have never heard of the lawsuit or that problem. i know that the Balance shafts had problems in he v6 models and the timing gear in some of the v8 models but never heard or seen anything about the cams failing
buggwuggy2017 is offline  
post #5 of 8 (permalink) Old 01-28-2017, 10:49 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2012
Vehicle: 2005 CLK320, 2005 C230
Location: Vancouver, WA
Posts: 14
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
I hope it isn't serious. What software do you use at work? I own a shop and we use a snapon Verus and shut track but I don't have access to the good stuff.
allwheeldrive is offline  
post #6 of 8 (permalink) Old 01-28-2017, 10:51 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2012
Vehicle: 2005 CLK320, 2005 C230
Location: Vancouver, WA
Posts: 14
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
allwheeldrive is offline  
post #7 of 8 (permalink) Old 01-28-2017, 10:53 AM
BenzWorld Junior Member
 
Date registered: Jan 2017
Posts: 24
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
i have access to the original mercedes benz software that the dealer has. ther is a company out of LAsVEgas that offers it
buggwuggy2017 is offline  
post #8 of 8 (permalink) Old 04-30-2017, 09:56 AM
BenzWorld Junior Member
 
Date registered: Jul 2005
Posts: 38
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
156 engine failures?

I have owned our 2007 ML63 AMG for three years. It still is in mint condition and has less than 133,000 miles on it. So far only an idler pulley and the engine coolant thermostat have failed. My wife and I treat it with 'kids gloves' and drive it with medium (89 octane) gasoline, never exceeding 2,500 engine RPM. As a result we consistently average 16 mpg by the tank full. The failures discussed above must be caused when the car is driven to its design limits. Otherwise, the ML63 AMG is one of the safest SUVs on the road. Last year I also bought a 2012 S63 AMG with a 100,000 miles on it. What a car! It has a 10-1 compression ratio, does 60 mph at 1,500 RPM and 80 at 2,000 and averages 20 mpg. You may laugh, but keeping accurate track of your fuel consumption is a great indicator of engine health. :-)
Friedolin is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz AMG Forums > General AMG

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome