AMG 6.3 a POS? - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 02-04-2011, 11:51 AM
BenzWorld Junior Member
 
Date registered: Jan 2011
Vehicle: 2008 ML63 AMG.... Everything except Distronic! Bone Stock
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
AMG 6.3 a POS?

Is the 6.3l AMG V8 a piece of crap? After reading posts and now dealing with my 08 ML63 I am beginning to loose faith in German Engineering. I bought my ML63 2.5 weeks ago..... And it's been sitting in service for the past week. Bought it CPO from the dealership with 39,892 miles. At 40,125 it went back to the dealer for a slew of issues. The main issue was the sound of the engine. Tap Tap Tap Tap Tap Tap Tap Tap in perfect sync with the rotation and rpm's, It's present at cold starts as well as after being driven for a duration of time. The drivers side head is beyond noisy whereas the passenger side sounds normal. At first there was no sound but after a 100+ miles of driving it now makes a horrid sound. I've read pages of forum postings regarding noises and such... Mostly the ticking / tapping sound. What I have noticed is that 99.9% of people mentioning ticking / tapping say it comes from the drivers side of the engine. Obviously MB knows about this issue as from the looks of it many have brought their cars to their SA's. Did they engineer this engine to self destruct, All it takes it a spirited drive with a low oil level to wreak havoc. As for my ML.... The SA says the cam adjuster are bad and they have ordered the parts but they said once they open the valve cover they may find more damage / issues. My tapping was coming from about center of the valve cover, Scored Tappet? For being such a well engineered engine why in the hell does the general 6.3 owner have to feed it 1/2 to 1 quart of oil per every 1000 miles driven? Why's it burning oil?? My Dodge Cummins truck goes 10,000 miles without burning any oil.... And it's tuned to 544rwhp with 962ft/lbs. I'm sorry but a $100k car should not sound like 1976 Vega with 214k miles while idling. Besides the tapping noise we also have the noisy belt idlers which all seem to oscillate on their shafts instead of rolling true and straight. SA said that was normal for play to be present on the idlers. The service history from the previous owner shows they had brought it in at 34k for the same issue, MB replaced an idler and the belt..... But they installed the belt wrong as I discovered.... The belt was installed with 2 ribs hanging over the rear shoulder of the power steering pump pulley. Luckily it's under warranty for 100k or 11/04/2014, I'm beginning to believe this is not a car to be kept once the warranty is up.


Here's a 2008 6.3l engine with 921 miles on it.... Seized from lack of oil on Ebay. Looks as if MB replaced it as the seized motor will ship on a AMG factory shipping stand.

Ebay item # 200565097080

Last edited by R.Taylor; 02-05-2011 at 12:06 AM. Reason: wrong url
R.Taylor is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-04-2011, 12:23 PM
BenzWorld Junior Member
 
Date registered: Jan 2011
Vehicle: 2008 ML63 AMG.... Everything except Distronic! Bone Stock
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I forgot to mention:

The previous owner had brought it to service 3 times for "Check oil" light.

@ 2229 miles - 1.5q added.
@ 3839 miles - 1.5q added.
@ 8535 miles - 1q added.

All three lines state the same correction:

"Owner advised oil consumption is normal for this engine"

I'm sorry but 1.5 quarts at only 2229 miles seems excessive.... And another 1.5qts 1610 miles later. Seeing the previous owners service history leads me to think that they drove it around quite often with the check oil light on... With a below normal oil level. Obviously to stupid to check the oil when the light came on. Could driving it with 1.5qt less oil cause any damage. So is MB/AMG saying it's normal to burn a quart of oil per 1000 miles? They recommend an oil change every 10k miles but my math tells me that I'll have added 10 quarts of fresh oil by the time I am due for a 10k oil change, At a rate like that why doesn't MB/AMG just advise a oil filter change every 10k. Even 10k seems a bit long between oil changes... I've always been set on changing oils at 5k to 6k.
R.Taylor is offline  
#3 (permalink) Old 02-04-2011, 01:18 PM
POS
BenzWorld Elite
 
POS's Avatar
 
Date registered: Oct 2005
Vehicle: 1983 300TD Wagon, 1966 250SE Cab
Location: Texas
Posts: 3,441
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I haven't done any research on the 6.3 to know if it's good or bad, but if I had a newer vehicle that burned that much oil, I wouldn't call it "normal" consumption. The only thing I do know about these things is that my brother-in-law had a 1999 ML55 for a few years, and he seemed to be always chasing interior bits breaking and sensors failing. He never had any engine issues though.

- Brian



1969 Porsche 911S Targa
1966 Mercedes 250SE Cabriolet
POS is offline  
#4 (permalink) Old 02-04-2011, 01:47 PM
BenzWorld Junior Member
 
Date registered: Jan 2011
Vehicle: 2008 ML63 AMG.... Everything except Distronic! Bone Stock
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I'm beginning to believe the original owner of this car beat the crap out of it fresh off the showroom floor. A good hint is the blown front speaker... I'm sorry but you'd gotta maxing the volume on the radio to do so.... Great. Speakers don't go bad from normal listening levels. After reading many posts on many different MB forums I've noticed that all who mention tapping and ticking sounds state that it's coming from the drivers side. Not one mention of it being the passenger side. Hmmm.... Design flaw? That along with "Normal" oil consumption of 1qt per 1k miles says that something is not right. If I wanted a 2-stroke vehicle I'd have bought a Trabant or a vintage Saab.

Last edited by R.Taylor; 02-05-2011 at 12:07 AM.
R.Taylor is offline  
#5 (permalink) Old 02-04-2011, 08:29 PM
BenzWorld Junior Member
 
Date registered: Jan 2011
Vehicle: 2008 ML63 AMG.... Everything except Distronic! Bone Stock
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Hellooo.... Anyone have anything to say....
R.Taylor is offline  
#6 (permalink) Old 02-05-2011, 02:41 AM
BenzWorld Member
 
DuaneC63's Avatar
 
Date registered: Mar 2010
Posts: 221
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by R.Taylor View Post
Hellooo.... Anyone have anything to say....
Never had any problems with V-8 AMG's 4.3, 5.5n/a or 6.3. My 6.3 does use a quart every 2,000 miles but if you had Porsches, thats not a scary amount. Sounds like your correct that the orginal owner may have been a bit hard on the break in period. The good news is the car was CPO, you have a long warranty period and you get another MBZ as a loner when your's is in the shop. I've heard more problems with the 5.5SC motor overheating and oil usage. Hope they have better luck with the 5.5 Turbo motor coming out.

Current
09 AMG C63 Metallic Steel Grey
06 X3 Silver
03 996TTX50 Black
In Loving Memory of my Bank Account
05 AMG C55 Brilliant Silver
99 AMG C43 Black
97 M-3 4D Silver
95 325i 4D Black
85 318 coupe Black
95 993RS Black
85 911 Red
83 911 Cab White
80 911 Met Black
78 911 Cashmere

Last edited by DuaneC63; 02-05-2011 at 02:45 AM.
DuaneC63 is offline  
#7 (permalink) Old 02-05-2011, 08:35 AM
BenzWorld Elite
 
EvoGuy's Avatar
 
Date registered: Dec 2006
Vehicle: 2004 E500 Wagon, 2004 E55 AMG
Location: ATL
Posts: 1,327
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I agree with you Duane, all the high performance engines use oil. A friend of mine had an M3 that used the same amount if not more based on his driving style for that period. I'd not be worried about it if that car is a CPO.
EvoGuy is offline  
#8 (permalink) Old 02-05-2011, 10:32 AM
BenzWorld Elite
 
2000 C280 Sport's Avatar
 
Date registered: May 2008
Vehicle: 12 E350 4M,06 CL600,05 C240 4M,02 911C4,02 CLK430,99 F355,14 Dodge,55 Ford, Sea Ray
Location: Saratoga, NY. Sarasota, FL.
Posts: 1,503
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Sounds like this car was beat up on alot. Get the issue taken care of when you have it under CPO. It cost thousands to fix if not delt with soon. The 6.3 AMG motor is a good motor. Not as good a the 5.4 found in a E55 or a 5.5 v12. I had the S63 AMG as a loaner and the motor is very very nice. Its N/A and I think thats why people dont like it as much as the other aspirated AMG's. Many C63 owners love theirs as well and from looking around the motor is pretty solid so far.

WTB: 2012 CLS550 4M (C218) In spring of 2015.
2000 C280 Sport is offline  
#9 (permalink) Old 02-05-2011, 11:29 AM
BenzWorld Extremist
 
justinwrock's Avatar
 
Date registered: Jul 2005
Vehicle: see my signature.
Location: Sacramento, CA
Posts: 899
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to justinwrock
FYI - My local dealer had (at one point) 5 6.3 powered vehicles in for oil related issues.


One was an ML63 that had its engine rebuilt 2x, and was awaiting a crate motor from MB/AMG.

05 4200GT. Stock.
08 Ford F250 Crew Cab/Shortbox/Powerstroke 6.4/Spartan 310
justinwrock is offline  
#10 (permalink) Old 02-05-2011, 12:16 PM
BenzWorld Junior Member
 
Date registered: Jan 2011
Vehicle: 2008 ML63 AMG.... Everything except Distronic! Bone Stock
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by justinwrock View Post
FYI - My local dealer had (at one point) 5 6.3 powered vehicles in for oil related issues.


One was an ML63 that had its engine rebuilt 2x, and was awaiting a crate motor from MB/AMG.
Very strange.... Obviously there is some issue that MB/AMG are aware of. Can I read the oil pressure sensor off the ODB port? I'm curious as to what the idle and driving oil pressures are. It would be nice if someone made a pillar gauge pod, An ODBII gauge from like PLX Devices or AeroForce would be a welcome addition. Stock fuel and temp gauge is not enough information for a "hot rod" V8, You think they'd have an oil pressure gauge in the cluster.

Previous Mercedes:

1989 W126 560SEL Euro

Current Vehicles:

08 AMG ML63 - Stock
06 Dodge Megacab Diesel (544rwhp/962ft/lbs)
05 VW R32 GTI - Stock
04 Volvo XC70 R (Evolve Tuned 320hp)

RIP:

68 Ford/Lotus Cortina MkII GT (Factory rally prepped)
R.Taylor is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz AMG Forums > General AMG

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
I need to get a life. I need to be more Pos. ThrillKill Off-Topic 2 11-27-2010 08:57 PM
POS, take a look at this! brucemendel W126 S,SE,SEC,SEL,SD,SDL Class 2 03-03-2010 10:35 PM
Try this with your POS Benz GMISBEST. Off-Topic 7 02-22-2010 11:05 PM
Hey POS...! Digmenow R/C107 SL/SLC Class 2 02-17-2009 08:23 PM
PSE? POS! DickB R170 SLK Class 1 05-13-2008 05:34 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome