2004 clk320 brake wear sensor question - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-03-2009, 09:42 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2009
Vehicle: 2004 CLK 320
Location: massachusetts
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
2004 clk320 brake wear sensor question

Hi all,

Just joined and I have a question regarding the pad replacement in my 2004 clk 320. Do I need to replace the wear sensors when I replace the pads and will that reset the message when I do or is there somthing I need to do in order to reset the message?
twistedmetalman is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-06-2009, 01:33 PM
BenzWorld Elite
 
keyhole's Avatar
 
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 10,272
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 327 Post(s)
Hi tmm - welcome to the forum.

It seems to be the accepted wisdom to always replace the wear sensor when a pad is replaced, if the wheel has one. Not all wheels have a sensor, and they are not expensive.

My understanding is that the fault message will (eventually) clear itself. If I am wrong about this, someone else will quickly correct me!
keyhole is online now  
post #3 of 4 (permalink) Old 10-06-2009, 04:39 PM
BenzWorld Member
 
Date registered: May 2005
Vehicle: 2004 clk55 amg
Location: Charleston, SC
Posts: 270
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by keyhole View Post
Hi tmm - welcome to the forum.

It seems to be the accepted wisdom to always replace the wear sensor when a pad is replaced, if the wheel has one. Not all wheels have a sensor, and they are not expensive.

My understanding is that the fault message will (eventually) clear itself. If I am wrong about this, someone else will quickly correct me!
yes, in order to reset, you must run around the car 3x's backwards. and as usual, keyhole is correct.
blk05c230k is offline  
post #4 of 4 (permalink) Old 10-07-2009, 01:54 AM
BenzWorld Extremist
 
unitfreebie's Avatar
 
Date registered: Oct 2007
Vehicle: 2006 CLK 350
Location: Fog City California
Posts: 1,133
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My car (2006) only has sensors on the right side brake, none on the left brakes... Also the sensor wires are very thin and might break when pulling it off the old pads, so it's best to install new ones which you can get from AutohausAZ.

The Brake Light will turn off by itself if the sensor is GOOD.

Also besides running around backwards, bending over for the Dealer will always RESET the brake light! Hahaha
unitfreebie is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Coupe/Convertible Forums > C209/A209 CLK-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    User Tag List

    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    driving w/ brake wear sensor on jesster W203 C-Class 7 11-13-2008 09:40 AM
    Brake pad wear sensor? bossman123 W210 E-Class 5 11-30-2007 04:42 PM
    Brake Wear Sensor jallbutt W124 E,CE,D,TD Class 3 08-23-2004 04:06 PM
    Brake wear sensor M Arrow W163 M-Class 1 02-07-2004 11:06 AM
    Brake wear sensor - does it work? sdgrossman1 W124 E,CE,D,TD Class 6 10-13-2003 12:17 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome