How to test ac blower regulator - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 04-24-2009, 02:41 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2008
Vehicle: 99 SLK 230 Sport
Location: Sacramento
Posts: 33
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
How to test ac blower regulator

Does anyone know how to test an ac/heater blower regulator? My girlfriend have a 99 CLK 320 and the fan is not working. I think it's the regulator but would like to test it before spending $169 on it.

thanks
yatwing is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 04-24-2009, 01:04 PM
BenzWorld Member
 
Date registered: Mar 2008
Vehicle: CLS550 Master Lease, 1990 300zxTT, 2000 camry
Location: Augusta, Ga
Posts: 361
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
There really is no easy way to test the regulator. But it has been my experience that if the regulator goes bad it is because of the blower motor. I would pull the blower motor and regulator out since they are in the same unit and easy to remove and see if maybe it looks like you have had water in the case or anything like that. Really all you can test for at the regulator is power and ground because I think the signal wire from the a/c control unit is PWM(pulse width modulated) and you would need an oscilloscope to test it.
kyle21nluvnit is offline  
post #3 of 8 (permalink) Old 04-25-2009, 02:40 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2008
Vehicle: 99 SLK 230 Sport
Location: Sacramento
Posts: 33
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
thanks, I'll pull the blower tomorrow to check it out.
yatwing is offline  
post #4 of 8 (permalink) Old 04-27-2009, 02:53 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2008
Vehicle: 99 SLK 230 Sport
Location: Sacramento
Posts: 33
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Well, It turns out the contacts where rusted. Disconnected it and reconnected it and it started to work again. A quick fixed but I think next weekend I'm going to take the fan assembly off and clean it up better.
yatwing is offline  
post #5 of 8 (permalink) Old 07-17-2009, 09:34 PM
BenzWorld Junior Member
 
Date registered: Aug 2004
Vehicle: 1998 SL500, 2002 CLK430
Location: Upper Marlboro, MD
Posts: 19
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Yahoo to queenpumpkin
My ac motor is not working in my 02 CLK 430. Can you tell me where to find it how to remove it? Female working on her own car...any help appreciated.
queenpumpkin is offline  
post #6 of 8 (permalink) Old 12-07-2009, 06:52 PM
BenzWorld Junior Member
 
Date registered: Mar 2009
Vehicle: 1999 CLK 430
Location: West Babylon, NY
Posts: 24
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Yahoo to johnsmohr111
Thumbs up Cleaned the contacts on ac/heat blower motor

Quote:
Originally Posted by yatwing View Post
Well, It turns out the contacts where rusted. Disconnected it and reconnected it and it started to work again. A quick fixed but I think next weekend I'm going to take the fan assembly off and clean it up better.
Just had same issue with my 99 clk 430 found how to take out on another thread on here and cleaned up contacts. Wallah works like a charm Thanks for the advice this site is awesome.
johnsmohr111 is offline  
post #7 of 8 (permalink) Old 12-07-2009, 10:41 PM
BenzWorld Elite
 
Date registered: May 2005
Vehicle: 99CLK320
Location: Lincoln, NE 68516-6548
Posts: 1,480
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
John, would you please post a link to that fix. Good one to keep on file. TIA!
dlbehrns is offline  
post #8 of 8 (permalink) Old 12-07-2009, 10:55 PM
BenzWorld Junior Member
 
Date registered: Mar 2009
Vehicle: 1999 CLK 430
Location: West Babylon, NY
Posts: 24
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Yahoo to johnsmohr111
Quote:
Originally Posted by dlbehrns View Post
John, would you please post a link to that fix. Good one to keep on file. TIA!
I used the diagram from this tread to locate and take out, not same model but in same location and pretty much the same as my unit. Hope it helps everyone.

http://www.benzworld.org/forums/w208...regulator.html

BTW it took me about 1/2 hour to take out clean and put back. Very simple.
johnsmohr111 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Coupe/Convertible Forums > C208/A208 CLK-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode


    Forum Jump

    Similar Threads
    Topic Author Forum Replies Last Post
    1998 W210 E300DT Bad Blower Regulator or Blower Motor?? How to tell DieselNuts W210 E-Class 12 08-16-2012 12:32 PM
    1994 S500V W140 BLOWER AND BLOWER REGULATOR dbs600 W140 S-Class 8 02-13-2012 04:01 PM
    blower regulator mmir110 W126 S,SE,SEC,SEL,SD,SDL Class 1 02-27-2008 03:24 PM
    Need a Blower regulator ????? Big"D"inTheMB W210 E-Class 0 07-19-2007 02:43 PM
    Blower Regulator pollyperkins13 W140 S-Class 3 11-28-2005 10:57 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome