Check engine light, but the car feels great!? - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 06-15-2008, 11:45 PM Thread Starter
BenzWorld Member
 
gizzo's Avatar
 
Date registered: Apr 2004
Vehicle: 89' 190e 2.6 / 02' CLK55 AMG
Location: Playa del Rey, CA
Posts: 138
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Check engine light, but the car feels great!?

I've only owned this car for about 1k miles and was serviced by MB before i bought it. So ya this light popped up on me tonight.

Car doesn't feel any different. No lag in accel, no rough idle. Checked fluids.
I hope its just bad gas.
Is it worth buying a code checker? I can do alota basic service myself.

I hope my baby is okay


CLK55 - 2002 / E320 - 2003
Vogtland Springs / Koni Sp / VIPclk320 R Strut
OZ Ultraleggera lightweight (18.3 lb)
Green Filters + Race Cats / SprintBooster
Pioneer AVIC-X910BT / Basslink
Cailbre K40 Hidden Radar Jammer
Ceramic 20% Gloss Tint
gizzo is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 06-16-2008, 06:53 AM
BenzWorld Member
 
nmilsaps's Avatar
 
Date registered: Mar 2007
Vehicle: 2001 CLK 430
Location: Houston, TX
Posts: 159
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Congrats and welcome.
Autozone has a code reader that they have used on my car for free. I'd try that first, if they have them in CA.
nmilsaps is offline  
post #3 of 14 (permalink) Old 06-16-2008, 10:54 AM
BenzWorld Junior Member
 
Cinellipro's Avatar
 
Date registered: May 2008
Vehicle: CLK320 1999 Black/Black/Black
Location: South Florida
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
A code checker is definitely worth it if you're a "do it yourself er." However, my check engine light was turning on intermittently. I was told by my mechanic that it has to do with the Ethanol being added to fuel that is not mixing well and is causing the sensors to get false readings.
He said stick to Chevron as they have not added the ethanol mix yet. I cannot say how much of this is reality, but when I started pumping Chevron the check engine light went off, and has stayed off.
Cinellipro is offline  
post #4 of 14 (permalink) Old 06-16-2008, 11:47 AM
BenzWorld Member
 
Date registered: Jul 2007
Vehicle: 2002 CLK 430
Location: Chicago, IL
Posts: 304
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
I had the exact same issue and it was because of the pressure in the fuel system... only going to feel something like that in pretty extreme driving circumstances. Then I got rear-ended and the other fixes fixed the problem.

Would also recommend the auto-zone free read. If you're gonna buy one then you have to decide if you want the standard readable (pretty cheap) or the one with all the extended MB codes (not as cheap, needs a computer connection)
skiflyer is offline  
post #5 of 14 (permalink) Old 06-16-2008, 02:01 PM
BenzWorld Senior Member
 
sfclk's Avatar
 
Date registered: Mar 2008
Vehicle: 1999 CLK320
Location: San Francisco
Posts: 446
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to sfclk
My CEL also comes on and off. It turns off usually after 3 drives of 20 mins each.

Next time the CEL comes on I'll take it to Autozone.

Then maybe then, I'll try filling with Chevron instead of Shell.
sfclk is offline  
post #6 of 14 (permalink) Old 06-17-2008, 07:21 AM
BenzWorld Member
 
unlukky's Avatar
 
Date registered: May 2007
Vehicle: 2006 CLS500
Location: Fort Worth, TX
Posts: 348
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Cool

Check code
Reset code
Fill up with good gas
install gas cap (ensure its tight and the seal is good)

DrIVe ...

If no more light, no more problem
If light come back, check code again. At least that will start loggin you some troubleshooting history.


--John
2006 CLS500
unlukky is offline  
post #7 of 14 (permalink) Old 06-18-2008, 10:04 PM Thread Starter
BenzWorld Member
 
gizzo's Avatar
 
Date registered: Apr 2004
Vehicle: 89' 190e 2.6 / 02' CLK55 AMG
Location: Playa del Rey, CA
Posts: 138
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
So the check engine light disapeared wasn't able to check what it was.

But now when i start the car, the 2 red lights at the top of the instrument cluster light up. Then make sounds like a radar detector with the beeps and stuff then go to green light, after the red lights flicker.
Is this the SOS system, i did push the info button a few days ago.

Don't see any referance to it in the manual



CLK55 - 2002 / E320 - 2003
Vogtland Springs / Koni Sp / VIPclk320 R Strut
OZ Ultraleggera lightweight (18.3 lb)
Green Filters + Race Cats / SprintBooster
Pioneer AVIC-X910BT / Basslink
Cailbre K40 Hidden Radar Jammer
Ceramic 20% Gloss Tint

Last edited by gizzo; 06-18-2008 at 10:47 PM.
gizzo is offline  
post #8 of 14 (permalink) Old 06-21-2008, 12:46 AM Thread Starter
BenzWorld Member
 
gizzo's Avatar
 
Date registered: Apr 2004
Vehicle: 89' 190e 2.6 / 02' CLK55 AMG
Location: Playa del Rey, CA
Posts: 138
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
any ideas?


CLK55 - 2002 / E320 - 2003
Vogtland Springs / Koni Sp / VIPclk320 R Strut
OZ Ultraleggera lightweight (18.3 lb)
Green Filters + Race Cats / SprintBooster
Pioneer AVIC-X910BT / Basslink
Cailbre K40 Hidden Radar Jammer
Ceramic 20% Gloss Tint
gizzo is offline  
post #9 of 14 (permalink) Old 06-24-2008, 05:22 AM
BenzWorld Member
 
unlukky's Avatar
 
Date registered: May 2007
Vehicle: 2006 CLS500
Location: Fort Worth, TX
Posts: 348
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Post

I believe that even if u dont currently have the CEL light, you can still check fault history. Not sure though. Might have even been the gas cap. I have no idea what those lights are. I have an '01. They should be the same. I'll check the next time I get in...


--John
2006 CLS500
unlukky is offline  
post #10 of 14 (permalink) Old 06-24-2008, 09:24 AM
BenzWorld Member
 
Date registered: May 2005
Vehicle: 2000 CLK 430
Location: NC
Posts: 99
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My car had a flat tire, I jacked it up to replaced with the spare tire. After that I replaced the air filters. The next day CEL came on. Without doing anything I drove for 2 days and it was gone. A day later it came on again and has stayed on. I don't feel like losing any power, idle is great. It's still on the spare tire. anybody know if changing the filters or jacking the car up, or running on the spare tire could cause the CEL to come on? Is there any way to reset it?
benzo4me is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Coupe/Convertible Forums > C208/A208 CLK-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    User Tag List

    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Check Engine Light / Car Stalls @ Stop Light jasonryan11 R171 SLK-Class 2 08-03-2007 06:56 AM
    Bottom of car got scraped, then check engine light came on JJB236 W124 E,CE,D,TD Class 5 02-01-2007 05:00 PM
    Check Engine Light is ON and car rumbles... EUROSOE W203 C-Class 9 01-14-2007 10:42 AM
    So my check engine light came on. I took car to the Carlo$ R129 SL-Class 1 04-30-2004 10:23 AM
    Check engine light back on - feels like home again. ScubaDriver W163 M-Class 0 10-14-2003 08:30 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome