05 SL500 Flash update COMAND for XM receiver - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Technical Forums > Audio & Telematics Forum
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-06-2010, 03:02 PM   #1 (permalink)
BenzWorld Junior Member
 
Date registered: Sep 2010
Vehicle: 2005 SL500, 1977 450SL, 2007 Cadillac Escalade
Location: San Diego, CA, USA
Posts: 13
05 SL500 Flash update COMAND for XM receiver

Just had a mObridge XM receiver installed in my '05 SL500. It works like the factory Sirius through the COMAND but has some quirks. MB dealer says a flash update to a 2008 version will fix the problem. He wants 1 hour labor. Anyone have any experience with this? What else will the update do (any benefit or detriment?) and will my 2005 nav disk still work? Thanks.
robdog is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-07-2010, 04:16 PM   #2 (permalink)
BenzWorld Veteran
 
Date registered: Mar 2006
Vehicle: 2005 CL65 AMG, 2007 Ferrari F430
Location: Atlanta
Posts: 790
What kind of quirks are you having? We use the same hardware that the Mobridge sat unit uses (Fiberdyne), but slightly different software that we load. Maybe we can help.
InCarTronics is offline   Reply With Quote
Old 10-07-2010, 05:14 PM   #3 (permalink)
BenzWorld Junior Member
 
Date registered: Sep 2010
Vehicle: 2005 SL500, 1977 450SL, 2007 Cadillac Escalade
Location: San Diego, CA, USA
Posts: 13
Quote:
Originally Posted by InCarTronics View Post
What kind of quirks are you having? We use the same hardware that the Mobridge sat unit uses (Fiberdyne), but slightly different software that we load. Maybe we can help.
Doesn't always remember the station on restart, changes stations without being touched, switches to CD or radio without being touched, often displays 'acquiring' but the music is uninterrupted, plays one station while displaying another, reboots the COMAND unit, COMAND won't always start up right away. mObridge and Mercedes both think an update of my firmware(?) to the 2008 version will solve the problem. According to mObridge, they've tested their software and it works, but the 05 was a 'transition' year and some of the software got updated in later models. My car is MY2005 and I'm not sure what exactly this update will do, including render my nav cd useless (05 version). When I purchased the XM I was told it would work exactly like the factory Sirius, and mObridge knew my MY, and I think even my VIN when the installer ordered the part.
robdog is offline   Reply With Quote
Old 10-07-2010, 07:07 PM   #4 (permalink)
BenzWorld Veteran
 
Date registered: Mar 2006
Vehicle: 2005 CL65 AMG, 2007 Ferrari F430
Location: Atlanta
Posts: 790
That sounds beyond mObridge issue, even on their software. It could be a install issue as well. Possibly an loop order problem that can be resolved with a STAR DAS. In any event, updating your software will not be anything negative, only positive.
You have a Siemens head unit, which does have special considerations. You are welcome to write to us from our website (see this screen name), and we may be able to assist you further. Unfortunately there are a lot of dealers selling the mObridge brand that should not be. Hopefully this is not your case.
InCarTronics is offline   Reply With Quote
Old 10-15-2010, 12:27 PM   #5 (permalink)
BenzWorld Junior Member
 
Date registered: Sep 2010
Vehicle: 2005 SL500, 1977 450SL, 2007 Cadillac Escalade
Location: San Diego, CA, USA
Posts: 13
Quote:
Originally Posted by InCarTronics View Post
That sounds beyond mObridge issue, even on their software. It could be a install issue as well. Possibly an loop order problem that can be resolved with a STAR DAS. In any event, updating your software will not be anything negative, only positive.
You have a Siemens head unit, which does have special considerations. You are welcome to write to us from our website (see this screen name), and we may be able to assist you further. Unfortunately there are a lot of dealers selling the mObridge brand that should not be. Hopefully this is not your case.
I spoke with MB - evidently these types of issues occur even with the factory Sirius unit. According to the MB tech there have been several audio/COMAND updates from MB over the years, most to correct bugs in previous updates. He tells me it will not affect my nav - my '05 disk will still work after update.
robdog is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Technical Forums > Audio & Telematics Forum

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
Turn Signal Flash & combined Side Marker Flash graybeard R/C107 SL/SLC Class 11 07-27-2013 03:57 PM
Flash update COMAND for XM receiver robdog R230 SL Class 2 03-25-2011 07:52 AM
comand 2.5 update patrick251981 W220 S-Class 3 11-20-2009 10:57 AM
Comand Update (CD) billmeu W208 CLK Class 0 09-08-2008 07:28 PM
98 SL500 Won't crank and the side markers flash dane8303 R129 SL Class 4 02-07-2006 07:59 AM


All times are GMT -7. The time now is 03:28 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.