Mercedes-Benz Forum - View Profile: ps2cho

ps2cho ps2cho is offline

BenzWorld Elite

  Visitor Messages

Showing Visitor Messages 1 to 10 of 18
  1. jl772009
    04-04-2014 08:10 AM - permalink
    jl772009
    I just wanted to say that is a nice 88 TE
  2. adler
    12-18-2013 05:36 AM - permalink
    adler
    Hello!
    Do you have your transmission repair chronicled here?
    regards
    Ad
  3. ps2cho
    12-09-2012 10:18 PM - permalink
    ps2cho
    I have done the later model cladding upgrade, but it is in fact an 88.
  4. Bobbyturbodiesel1987
    11-30-2012 01:12 AM - permalink
    Bobbyturbodiesel1987
    That wagon doesn't look like an 1988
  5. jeanvill
    11-15-2012 01:04 AM - permalink
    jeanvill
    hey Robert. How have you been?
  6. ps2cho
    01-27-2012 08:05 PM - permalink
    ps2cho
    You can use my username or Robert....whatever you feel like
  7. 300E91
    01-17-2012 10:07 PM - permalink
    300E91
    Whenever I link to 124zone I make reference to "another users of this site." Is there something else that you might prefer, maybe more direct? You've got a great site.
  8. 300E91
    01-02-2012 05:03 PM - permalink
    300E91
    Zonealarm just popped a warning when I went to your w124 site to look for a link for another user here. I'm guessing that there's a way to validate your site and avoid this warning.

    It's a great resource and a shame if the warning scares some users away.
  9. pcreteau
    07-08-2011 06:54 AM - permalink
    pcreteau
    As you have experience taking out the gas tank from your 300TE, could you tell me if there is an access panel above the tank in the cargo compartment that will allow disconnecting of the fuel level sending device or any additional attachment fittings? If so, how do you get to it? What must be taken out of the compartment to get to it? I have an 89 300TE and am having difficulty getting the tank out. I must be missing something. Thanks so much for your thoughts.
  10. fstbkcuda
    04-20-2011 09:36 PM - permalink
    fstbkcuda
    I have a climate control question/issue for you. I have a 1991 300E and the climate control does what it wants. The thumb wheel is set to cold and I get heat out the defrost and right and left vents, sometimes if I'm on the expressway the heat will let off and I will get air consistent to what temperature I have it set at. I have replaced to mono valve and the car has been converted from R12, would replacing the CCU be of any help or just and excuse to spend $400? Any help would be appreciated as it's starting to get warm and it really sucks driving around with the heat stuck on

  About Me

  • About ps2cho
    Vehicle
    1988 300TE, 2002 CLK320
    Location
    Chandler, AZ
  • Signature
    W124-Zone.com
    1988 Pearl Grey Metallic Mercedes 300TE - 154k
    2002 Silver CLK320 - 142k
    2014 Jeep Wranger Unlimited Sahara - 6k

    FS: Authentic AMG Gen I body kit (local AZ only). PM Me!

  Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Today 06:21 AM
  • Date registered: 10-08-2006
  • Referrals: 0

  Friends

Showing Friends 1 to 6 of 6
  • adler
    • adler
    • BenzWorld Senior Member
    • adler is offline
  • breatle62
    • breatle62 is offline
  • coldfoil
    • coldfoil is offline
    • Send a message via Skype™ to coldfoil
  • deep3175
    • deep3175 is offline
  • DOLLARBENZ
    • DOLLARBENZ is offline
  • jeanvill
    • jeanvill is offline

  Mentions

09-19-2014
09:33 AM - Xmsteel mentioned ps2cho in post 300TE Enters the Twilight Zone
...ETA on autohaus. ps2cho - I assume these hos...

  Thread Tags

No results to display...

  Quotes

09-25-2014
08:36 AM - euroamg quoted ps2cho in post Summer car Mercedes 300E 24
How did you fit the Gen I s...
09-23-2014
05:05 AM - BenzQC quoted ps2cho in post Need to diagnosis for vacuum door locks
How much are new door cards...
09-22-2014
07:43 PM - Real1shepherd quoted ps2cho in post Need to diagnosis for vacuum door locks
How much are new door cards...
09-21-2014
04:39 AM - Clarkz71 quoted ps2cho in post Clark tech info, M103 Chilled Cam
Just run 15-40 Diesel oil l...
09-20-2014
11:51 AM - oefvetw124lover quoted ps2cho in post too damn high
The MB wasn't even broken d...
09-19-2014
07:47 AM - ps2cho quoted Xmsteel in post 300TE Enters the Twilight Zone
* When its having its issue,...
09-18-2014
08:31 AM - sbaert quoted ps2cho in post !987 260e - A/C not functioning at high heat
Well propanes not going to ...
07:38 AM - sbaert quoted ps2cho in post Are defroster vents supposed to be open 100% of time?
... I have noticed that on ...
12:50 AM - Clarkz71 quoted ps2cho in post Are defroster vents supposed to be open 100% of time?
I replaced all my vacuum po...
09-17-2014
06:44 PM - vaccin quoted ps2cho in post Are defroster vents supposed to be open 100% of time?
So are you saying it is sup...
09-15-2014
10:46 AM - tuttebenne quoted ps2cho in post Oil on plug. Engine guru needed!
Dang I feel stupid..I usual...
08:09 AM - Clarkz71 quoted ps2cho in post R12 pressures
Pshhh you're just jelly of ...
07:35 AM - ps2cho quoted Clarkz71 in post R12 pressures
...an endless supply of URO p...
07:27 AM - ps2cho quoted Clarkz71 in post Oil on plug. Engine guru needed!
He just did the complete head...
09-14-2014
06:55 PM - LogicalPosition quoted ps2cho in post "Moron" Might Be A Bit Harsh
Your professional is an utt...
06:19 PM - Clarkz71 quoted ps2cho in post Oil on plug. Engine guru needed!
Its the valve stem seals. T...
05:40 PM - ps2cho quoted LogicalPosition in post 1992 300CE Reverse Returns
....In his vast experience with tran...
09-02-2014
10:13 AM - abataineh quoted ps2cho in post common oil leak spots?
I am getting ready to do th...
08-29-2014
09:04 AM - jftu105 quoted ps2cho in post Got new radiator
This is wrong. Nissens is a...
08-28-2014
08:10 PM - ps2cho quoted 1mbzdoc in post Got new radiator
that brand is no better than...
 
For the best viewing experience please update your browser to Google Chrome