Mercedes-Benz Forum - View Profile: glenmore

glenmore glenmore is offline

BenzWorld Senior Member

  About Me

  • About glenmore
    Vehicle
    1999 C280, 2000 C280, 2000 C230K
    Location
    los angeles
  • Signature
    glenmore
    1999, 2000 C280
    2000 C230K

  Statistics

Total Posts
General Information
  • Last Activity: Yesterday 11:22 PM
  • Date registered: 09-14-2005
  • Referrals: 0

  Mentions

No results to display...

  Thread Tags

No results to display...

  Quotes

11-04-2014
01:09 PM - Vaka quoted glenmore in post 1999 C230K noise when turning left
This makes me think it has so...
11-03-2014
08:10 PM - glenmore quoted Vaka in post 1999 C230K noise when turning left
1999 C230 kompressor(W202...
10-20-2014
11:00 AM - lovemyc280 quoted glenmore in post Vacuum leak after O2 sensor change
I don't know how else to say ...
10-13-2014
03:40 PM - JohnnyDoe quoted glenmore in post 99 C230K New starter but not starting
You are correct. BTW, yo...
03:13 PM - glenmore quoted JohnnyDoe in post 99 C230K New starter but not starting
but his car does not even cran...
02:31 PM - JohnnyDoe quoted glenmore in post 99 C230K New starter but not starting
Crank position sensor in C280...
09-25-2014
07:27 AM - Han445 quoted glenmore in post My 98 c280 is stalling
My symptoms of a bad cranksha...
09-23-2014
02:58 PM - Han445 quoted glenmore in post My 98 c280 is stalling
So after it stalls, it starts...
09-02-2014
06:29 PM - Check Codes quoted glenmore in post CEL P0715, Limp mode, stuck 2nd gear,rough shift
When it rains it pours. Son ...
08-26-2014
05:57 PM - 00c230 quoted glenmore in post 2000 kompressor wont start
If some of these other sympto...
 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome