Mercedes-Benz Forum - View Profile: carnut62

carnut62 carnut62 is offline

BenzWorld Elite

  About Me

  • About carnut62
    Location
    Northern California USA
    Vehicle
    1966 250 (sold) 1981 300 CD (sold) 1972 280 SEL 4.5 (sold) 1971 280 114 Coupe (sold) 1988 300 SE
    Biography
    I sell new Mazda's.
    Interests
    Car restoration, art
    Occupation
    Internet auto sales
  • Signature

  Statistics

Total Posts
General Information
  • Last Activity: Yesterday 10:23 PM
  • Date registered: 02-22-2013
  • Referrals: 0

  Mentions

05-06-2015
08:20 AM - dadrab mentioned carnut62 in post How do I get the center dash vent vacuum pod out?
carnut62 - I know it's strayi...

  Thread Tags

No results to display...

  Quotes

05-01-2016
09:14 PM - VaiFanatic quoted carnut62 in post Has Anyone Ever.....
I bought yellow glass fog lig...
04-07-2016
08:19 AM - SF W126 quoted carnut62 in post What did you do to your 126 today?
76 posts and no complete prof...
03-23-2016
07:03 AM - GreenT quoted carnut62 in post Gen 1 W126 AC/Heater blower fuse
8 amp fuse seems low? verify ...
03-13-2016
08:28 AM - wooky_chew_bacca quoted carnut62 in post What did you do to your 126 today?
My 88 had a Celsius outside t...
03-03-2016
09:02 AM - liviu165 quoted carnut62 in post Steering jerks
jerking steering and loss of ...
02-17-2016
04:18 PM - xlimodriver quoted carnut62 in post Deleted Posts
04:13 PM - xlimodriver quoted carnut62 in post Anyone want a nice Suburban?
My suburban in the last year ...
01-20-2016
02:51 PM - wooky_chew_bacca quoted carnut62 in post Update cont...
Popsicle sticks and duct tape...
01-18-2016
04:52 PM - GreenT quoted carnut62 in post Update cont...
How about male pattern baldne...
10:15 AM - wooky_chew_bacca quoted carnut62 in post Update cont...
How about male pattern baldne...
05:47 AM - John350 quoted carnut62 in post Update cont...
Simply "edit" what you posted...
01-04-2016
05:40 PM - 86560sel quoted carnut62 in post '88 W126 instrument cluster relay / starting issue when cold/damp
You've either blown or cracke...
01-03-2016
07:17 PM - 86560sel quoted carnut62 in post '88 W126 instrument cluster relay / starting issue when cold/damp
You've either blown or cracke...
12-29-2015
04:46 PM - tahoe300SE quoted carnut62 in post 89 300SE throttle behavior / vacuum leak?
Lets get the terms correct. S...
12-28-2015
08:41 PM - carnut62 quoted tahoe300SE in post 89 300SE throttle behavior / vacuum leak?
Must be a vacuum leak. I muffle...
04:50 PM - tahoe300SE quoted carnut62 in post 89 300SE throttle behavior / vacuum leak?
When I "pass the gas" I too h...
12-20-2015
11:32 AM - NelsonM quoted carnut62 in post Hood Latch Issue
The length of the cable. Give...
12-19-2015
11:28 PM - NelsonM quoted carnut62 in post Hood Latch Issue
Have you tried adjusting the ...
10:32 PM - ColoRich quoted carnut62 in post Hood Latch Issue
Have you tried adjusting the ...
12-15-2015
08:25 AM - H.D. quoted carnut62 in post 91 560SEL hard cold start
Mine would do that and the "d...
 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome